Unread notifications not clearing / GameDev.tv logo behaviour

Hey, I’m having an issue where my unread notifications are not clearing after I read the indicated topic. Is anyone else having this problem?

Cant say that I have had that problem. I am using the latest version of Chrome and all seems well. There is an option that will clear all of your notifications but this isn’t perhaps ideal having to do it manually.

If you click on your avatar (top right), then on the cog, and notifications. There is an option there to clear them all.

Also, under preferences there are some options for the tracking of posts.

Other than that, perhaps a clear of temporary internet files/cache/cookies?

Weird. I’m also having an issue where, when I click on the gamedev.tv logo at the top, it doesn’t return to the forum homepage like it used to. It basically just adds a # to the end of the URL and keeps it on the same page I was on, and I’m having to go back and manually delete part of the URL to get back to the homepage.

Yep, I noticed that with the logo this evening also, on my mobile, but now also on the desktop site. There was most likely an upgrade over the last few days as I noticed my “title” has changed again on my profile, the upgrades for some reason seem to reset this.

If you click on the “Community” button it will take you to the forum home page.

@Ben - were/are you aware of any significant changes in any upgrades? The logo/title of the forum not linking to the main forum URL is a bit of a pain…

No updates I’m aware of, I wonder if it could be the work @sampattuzzi is doing to prepare to add our new Wordpress based blog to the header bar?

I thought the user title changes were am indication of upgrades?

Have there been some font size changes too @sampattuzzi - the text on the site looks a bit bigger than I remember it being (especially the column on the right hand side on the main page listing the lasted updates etc)

At the bottom each topics…

Selecting “Normal” will result in the specific topic no longer being marked as un-read…

It’s a bit less than ideal, but may help in the interim…

I had the problem for the first time today. Quitting Firefox and reloading the page didn’t help. I still have an “unread” message in Unity vs. Unreal that I read this morning. Ah yeah, the gamedev.tv logo doesn’t return to home for me either.

1 Like

Hello guys, this past week the GameDev header logo from this forum seems to show a weird behave and it is not redirecting to the home page anymore, anyone with this issue too?

1 Like

I’m glad somebody uses it! I just did a complete rewrite of the header to make it more responsive. I will add this functionality back.

1 Like

Is the font and logo issue fixed now?

Hey @sampattuzzi, yes, it appears to be working again now - not sure if it’s different or not, but when I clicked on it to get back to the main forum screen it seemed to reload the whole page a fresh, where-as typically before it’s always just felt like it went back? Not sure if it had a specific URL set before or just a javascript history function call before? In either case, it is working.


Yeah, definitely doesn’t feel quite the same, it appears to be doing a hard refresh each time at my end now, which means a bit of a wait for the page to load.

Font looks better yes, not as big now, so the topic titles tend not to wrap as much :thumbsup:

Uncertain whether it’s related to any other changes or not, but to be clear, the unread notifications are still b0rked :slight_smile:

I don’t think those are related to my changes unfortunately.

Hmmm… if it’s a Discourse update that’s a bit rough then… it’s incredibly frustrating…

*grumble* *moan* can’t cope with change *grumble* *moan* :smiley:

I have tried to improve the refresh. Does that work better?

1 Like

It’s probably a bit ambiguous as only me testing at this end and maybe the browser has started caching (or not), it does seem a bit quicker than it did when I responded a few minutes ago - I don’t remember seeing the spinner originally though as it loaded the posts. It may be that I just never noticed it, but it is noticeable at the moment.

I would typically be at the bottom of a topic with comments, click on the title and it would go back up a level, then displayed the GameDev.tv logo, which when clicked just went back instantly, from what I can remember. Sorry, probably not a great deal of help…

Just to add… it is literally only taking a second with the spinner, might just be my impatience! :slight_smile:


Also @sampattuzzi - have you resolved this? It doesn’t look to be navy anymore and appears to be the same as the rest of the screen? I will close the topic if so…

This one still needs resolving though, literally impossible to read.

…and I have noticed that the image backgrounds stop after the image height is met… did it do that before? This post is suitably long which demonstrates it well…

…as you are playing with the CSS etc :slight_smile: :slight_smile:

Glad it improved at least in perception.

I think we had that before.

I think this is solved indeed.

I really don’t remember it though, and it stands out a fair bit - the one for the lounge etc, I remember the topics scrolling, but not that big grey background?

Those other CSS items I guess you didn’t have time to look at Sam? I will leave those topics as open for now then.

Not sure if anything was changed with regards to the CSS for hyperlinks or not, but I noticed on the list of blocked Facebook users a lot of these now stay white as opposed to the behaviour that they had before, also, on mobile (phone in my case) the links in my longer response above to, they are white also - which left me thinking when I read your response that perhaps I hadn’t pasted the links in - but having returned the laptop they appear ok.

Whilst the logo behaviour is sorted, the unread items issue still exists - anyone checking on this?

Cheers :slight_smile:

I raised the issue about the unread notifications on the Discourse forum and got some feedback really quickly from @codinghorror and another member of there. Jeff turned off the customisation settings briefly to test whether it may have been any local changes that caused the issue - after he had done this the unread notifications started to work again. I asked him to pop the settings back as they were and mentioned that I would link to the thread here for the team etc…

The discussion can be seen here.

Unfortunately, as a new user on that form I hit the maximum number of replies for one day, so I can’t respond for 24 hours other than view updating existing posts, which may go unread/unnoticed.

Sorry about that! It does look like the CSS is a problem, in particular when height is set to 100%.

The customization is disabled at the moment. To re-enable:

  • Admin
  • Customize
  • “labels”
  • Check the “enabled” checkbox at lower right
1 Like

hehe, no worries Jeff, thanks for your help - I edited a post to try and let you know as I couldn’t reply any more today :slight_smile:

I will leave it for @Ben, @sampattuzzi and team to take a look at now but at least we have ruled out any updates/upgrades etc, and again, thanks for your help. :slight_smile:

Sam, the background images (lounge etc) don’t have the grey layer sliding over them now either.

1 Like

Privacy & Terms