Having Trouble Connecting To The Server

uem_s01_meet_the_clientserver_model

#1

Hi. Well, when connecting to the server running in the same computer, I get a short splash of the game, and immediately turns to a black screen. Joining with additional clients behaves in the same way. Tried the -windowed switch and same thing (but windowed).

Server log says:

[2017.10.07-08.44.10:698][420]LogNet: NotifyAcceptedConnection: Name: Entry, TimeStamp: 10/07/17 01:44:10, [UNetConnection] RemoteAddr: 127.0.0.1:58582, Name: IpConnection_1, Driver: GameNetDriver IpNetDriver_0, IsServer: YES, PC: NULL, Owner: NULL
[2017.10.07-08.44.10:699][420]LogNet: AddClientConnection: Added client connection: [UNetConnection] RemoteAddr: 127.0.0.1:58582, Name: IpConnection_1, Driver: GameNetDriver IpNetDriver_0, IsServer: YES, PC: NULL, Owner: NULL
[2017.10.07-08.44.10:729][421]LogNet: NotifyAcceptingChannel Control 0 server World /Engine/Maps/Entry.Entry: Accepted
[2017.10.07-08.44.10:729][421]LogNet: Remote platform little endian=1
[2017.10.07-08.44.10:731][421]LogNet: This platform little endian=1
[2017.10.07-08.44.10:795][423]LogNet: Login request: /Game/ThirdPersonCPP/Maps/ThirdPersonExampleMap?Name=Player userId: Invalid
[2017.10.07-08.44.10:828][424]LogNet: Client netspeed is 10000
[2017.10.07-08.44.10:927][427]LogNet: Join request: /Game/ThirdPersonCPP/Maps/ThirdPersonExampleMap?Name=Player?SplitscreenCount=1
[2017.10.07-08.44.10:930][427]LogNet: Join succeeded: Player

Client log says:

[2017.10.07-08.57.53:518][  0]LogNet: Game client on port 7777, rate 10000
[2017.10.07-08.57.53:519][  0]LogLoad: Error: Failed to enter /Game/ThirdPersonCPP/Maps/ThirdPersonExampleMap: . Please check the log for errors.
[2017.10.07-08.57.53:519][  0]LogNet: Browse: /Game/ThirdPersonCPP/Maps/ThirdPersonExampleMap?Name=Player
[2017.10.07-08.57.53:519][  0]LogLoadingSplash: Loading begins
[2017.10.07-08.57.53:519][  0]LogHMD: Initializing OVRPlugin session
[2017.10.07-08.57.53:544][  0]LogHMD: FSplash::OnShow
[2017.10.07-08.57.53:544][  0]LogLoad: LoadMap: /Game/ThirdPersonCPP/Maps/ThirdPersonExampleMap?Name=Player
[2017.10.07-08.57.53:565][  0]LogMemory: Platform Memory Stats for Windows
[2017.10.07-08.57.53:565][  0]LogMemory: Process Physical Memory: 851.73 MB used, 984.90 MB peak
[2017.10.07-08.57.53:566][  0]LogMemory: Process Virtual Memory: 979.00 MB used, 1059.13 MB peak
[2017.10.07-08.57.53:567][  0]LogMemory: Physical Memory: 8089.21 MB used,  7981.39 MB free, 16070.60 MB total
[2017.10.07-08.57.53:567][  0]LogMemory: Virtual Memory: 1625.00 MB used,  7981.39 MB free, 134217728.00 MB total
[2017.10.07-08.57.53:568][  0]LogMemory:
[2017.10.07-08.57.53:568][  0]Allocator Stats for TBB: (not implemented)
[2017.10.07-08.57.53:781][  0]LogAIModule: Creating AISystem for world ThirdPersonExampleMap
[2017.10.07-08.57.53:781][  0]LogLoad: Game class is 'PuzzlePlatformsGameMode'
[2017.10.07-08.57.53:786][  0]LogWorld: Bringing World /Game/ThirdPersonCPP/Maps/ThirdPersonExampleMap.ThirdPersonExampleMap up for play (max tick rate 0) at 2017.10.07-01.57.53
[2017.10.07-08.57.53:787][  0]LogWorld: Bringing up level for play took: 0.004057
[2017.10.07-08.57.53:796][  0]LogLoadingSplash: Loading ends
[2017.10.07-08.57.53:796][  0]LogHMD: FSplash::OnHide
[2017.10.07-08.57.53:797][  0]LogLoad: Took 0.253733 seconds to LoadMap(/Game/ThirdPersonCPP/Maps/ThirdPersonExampleMap)
[2017.10.07-08.57.53:968][  0]LogRenderer: Reallocating scene render targets to support 2560x1440 Format 10 NumSamples 1 (Frame:1).
[2017.10.07-08.57.53:968][  0]LogLoad: (Engine Initialization) Total time: 10.05 seconds
[2017.10.07-08.57.53:970][  0]LogLoad: (Engine Initialization) Total Blueprint compile time: 0.00 seconds
[2017.10.07-08.57.53:970][  0]LogExternalProfiler: Found external profiler: VSPerf
[2017.10.07-08.57.53:970][  0]LogExternalProfiler: Using external profiler: VSPerf
[2017.10.07-08.57.53:990][  0]LogOcInput: OculusInput is initialized
[2017.10.07-08.57.53:991][  0]LogHandshake: SendChallengeResponse. Timestamp: 26.294691, Cookie: 212053068090032235136171016021072008240218161125163020005255
[2017.10.07-08.57.54:041][  2]LogNetVersion: PuzzlePlatforms 1.0.0.0, NetCL: 3573198, EngineNetVer: 2, GameNetVer: 0 (Checksum: 3024838196)
[2017.10.07-08.57.54:041][  2]LogNet: UPendingNetGame::SendInitialJoin: Sending hello. [UNetConnection] RemoteAddr: 127.0.0.1:7777, Name: IpConnection_0, Driver: PendingNetDriver IpNetDriver_0, IsServer: NO, PC: NULL, Owner: NULL
[2017.10.07-08.57.54:094][  5]LogNet: Welcomed by server (Level: /Engine/Maps/Entry, Game: /Script/PuzzlePlatforms.PuzzlePlatformsGameMode)
[2017.10.07-08.57.54:094][  5]LogLoadingSplash: Loading begins
[2017.10.07-08.57.54:109][  5]LogHMD: FSplash::OnShow
[2017.10.07-08.57.54:109][  5]LogLoad: LoadMap: 127.0.0.1//Engine/Maps/Entry?Name=Player?game=/Script/PuzzlePlatforms.PuzzlePlatformsGameMode
[2017.10.07-08.57.54:131][  5]LogMemory: Platform Memory Stats for Windows
[2017.10.07-08.57.54:131][  5]LogMemory: Process Physical Memory: 924.76 MB used, 984.90 MB peak
[2017.10.07-08.57.54:133][  5]LogMemory: Process Virtual Memory: 1638.24 MB used, 1642.31 MB peak
[2017.10.07-08.57.54:133][  5]LogMemory: Physical Memory: 8185.49 MB used,  7885.11 MB free, 16070.60 MB total
[2017.10.07-08.57.54:133][  5]LogMemory: Virtual Memory: 2324.19 MB used,  7885.11 MB free, 134217728.00 MB total
[2017.10.07-08.57.54:133][  5]LogMemory:
[2017.10.07-08.57.54:134][  5]Allocator Stats for TBB: (not implemented)
[2017.10.07-08.57.54:137][  5]LogAIModule: Creating AISystem for world Entry
[2017.10.07-08.57.54:137][  5]LogTemp: Display: ParseSettings for GameNetDriver
[2017.10.07-08.57.54:138][  5]LogActorComponent: RegisterComponentWithWorld: (/Engine/Maps/Entry.Entry:PersistentLevel.WorldInfo_1.StaticMeshComponent0) Trying to register component with IsPendingKill() == true. Aborting.
[2017.10.07-08.57.54:138][  5]LogActorComponent: RegisterComponentWithWorld: (/Engine/Maps/Entry.Entry:PersistentLevel.WorldInfo_1.StaticMeshComponent0) Trying to register component with IsPendingKill() == true. Aborting.
[2017.10.07-08.57.54:139][  5]LogActorComponent: RegisterComponentWithWorld: (/Engine/Maps/Entry.Entry:PersistentLevel.WorldInfo_1.StaticMeshComponent0) Trying to register component with IsPendingKill() == true. Aborting.
[2017.10.07-08.57.54:139][  5]LogWorld: Bringing World /Engine/Maps/Entry.Entry up for play (max tick rate 0) at 2017.10.07-01.57.54
[2017.10.07-08.57.54:139][  5]LogWorld: Bringing up level for play took: 0.001446
[2017.10.07-08.57.54:140][  5]LogLoadingSplash: Loading ends
[2017.10.07-08.57.54:140][  5]LogHMD: FSplash::OnHide
[2017.10.07-08.57.54:148][  5]LogLoad: Took 0.038221 seconds to LoadMap(/Engine/Maps/Entry)

Be the first to post for 'Meet the Client-Server Model'!
#2

I struggled with this for a while. When launching your game client add :7779 to the end of your servers IP address. So it would be 10.0.0.23:7779


#3

Thank you for the suggestion Lochlenn. The game does run now with the :7779, but it isn’t really connected to the server, and when other clients connect (from the same PC), they don’t see the other players.

Regarding the port, it appears that is set in …\UE_4.17\Engine\Config\BaseEngine.ini, and is currently configured with:

[URL]
Protocol=unreal
Name=Player
SaveExt=usa
Port=7777
PeerPort=7778

I’m running UE4 version 4.17.2 and my command line is (omitted actual paths):

Server:
UE4Editor.exe PuzzlePlatforms.uproject -server -log

Client:
UE4Editor.exe PuzzlePlatforms.uproject 127.0.0.1 -game -log


#4

Also having the same issue here. Interestingly, I tried an experiment (as I am trying to port some multiplayer into the Infinite Runners project from the other UE4 course). If I attempt to connect on 7777, the HUD pops and I can fire, etc. I just can’t see anything. So it’s not that the game is locking up, but it seems like nothing but the HUD is rendering. I don’t really know what this means, but maybe it’s useful to someone.

I also get the issue if I am trying to connect on 7779 that I don’t see other clients (in fact, they seem to load into completely different levels entirely which leads me to believe they’re in fact not connecting to the server).


#5

Ok, I was able to resolve the issue after watching this tutorial. I basically added the map name and appended ?listen to it.

Like so (server command):
UE4Editor.exe PuzzlePlatforms.uproject ThirdPersonExampleMap?listen -server -log

The client is as before:
UE4Editor.exe PuzzlePlatforms.uproject 127.0.0.1 -game -log

[actual folder paths omitted]

I added 3 clients and they all saw each other.


#6

@sampattuzzi some great feedback here, you may want to dive-in.


#7

Didn’t quite work for me, but it got me on the right track. Good call on the ?listen argument. I just had to use my local ip instead of localhost (127.0.0.1) to make it work. Works like a charm now. :slight_smile:


#8

@apalopohapa thank you for this one, it worked for me.

I gotta feelin that in ver .2 of editor, there is something wrong with starting position, firstly it tries to attach my playerController to server figurine, then it gets under the map (kinda blackie down there) and finally it gets to the starting position. Also ‘?listen’ was not necessary to make it work, that inda fits to what can be a problem.

[2017.10.24-08.23.55:482][ 0]LogWorld: Bringing World /Engine/Maps/Entry.Entry up for play (max tick rate 30) at 2017.10.24-10.23.55
[2017.10.24-08.23.55:482][ 0]LogWorld: Bringing up level for play took: 0.002734
[2017.10.24-08.23.55:483][ 0]LogLoad: Took 0.176550 seconds to LoadMap(/Engine/Maps/Entry)


#9

Hello!
Seems like an excellent course!
I managed to connect client server and all that jazz using the port option (after getting the black screen at first).

But now, as I try play 2 players from the editor, player 2 gets a black screen there instead.
(It worked fine before I tried the client server task in the command prompt.)

Are these two connected somehow? Did anyone else get the same issue?

All the best! /Tomas


#10

Ooooh nevermind! It was a case of the classic: "have you tried turning it on and off again?"
I restarted the computer and now it works as before… Ignore me. lol


#11

Hey all, thanks for the great feedback. Is the gist that we need to add map + “?listen” in 4.17.2 forward. Is “Meet the Client/Server Model” the earliest lecture this problem happens with?


#12

I believe so.


#13

…and before anybody upgrades their project to 4.18.0, it has some bugs (still a preview version), though the one I’ve been bit by is mostly in blueprints (values set on nodes reverting to default automatically).


#14

Thank you apalopohapa, your post allowed me to resolve the issue


#15

I was having this same problem – and tried changing the port which didn’t work.

As soon as I added ThirdPersonExampleMap?listen to the server command it worked.

Then I also tried it with just ThirdPersonExampleMap and it worked too.

So… it would appear the important part is telling the server which map to load?


#16

Okay, I’ve added that to the video. Can anyone check those are the correct instructions?


#17

Not quite – the point was that I didn’t seem to need to use ?listen on the URL – my problem was that it NEEDED to have the map specified in order to avoid the black screen.

This also is related to a problem later in the course. Lecture 18 on ServerTravel – If I launched the game from the command prompt with -game enabled and lobby map specified in the parameters ie:

PS C:\Windows\system32> & “C:\Program Files\Epic Games\UE_4.18\Engine\Binaries\Win64\UE4Editor.exe” “C:\Users\ben_u\source\repos\UnrealCourse\PuzzlePlatform\PuzzlePlatform.uproject” -game -log -windowed -resx=1280 -resy=720

and then ran “Host” I could move into the game. However, if I then tried to join a new client from the command line with the IP specified and the ThirdPersonExampleMap map specified it did not join the server session – the result was two windows both in the ThirdPerson map individually but no multiplayer (ie only 1 person in each room).

PS C:\Windows\system32> & “C:\Program Files\Epic Games\UE_4.18\Engine\Binaries\Win64\UE4Editor.exe” “C:\Users\ben_u\source\repos\UnrealCourse\PuzzlePlatform\PuzzlePlatform.uproject” /Game/ThirdPersonCPP/Maps/ThirdPersonExampleMap 192.168.0.10 -game -log -windowed -resx=1280 -resy=720

The only way I was able to get the intended result of two people in the same room was to complete the following lecture on ClientTravel – then it all worked fine.


#18

Hello, I am having troubles with this course I am using UE4 4.16.3 I have tried using the ?listen for the server command and it is not working I also tried portforwarding the 7777 port and disabling my antivirus none have worked… I can’t seem to get them to be in the same “lobby or room” any help with this would be great! also I want to mention I noticed in the video I noticed at the end of the server the bottom text says external profile has been found mine tells me there hasn’t been found I am unsure if this causes issues for what I am trying to accomplish in the video but I figured it would be best to share with you as much as I can to help solve this problem. Thank you in advance!


#19

I am reporting back to say that I have resolved this issue. I wasn’t paying attention well enough to how I was writing out the directory for the map /Game/ not Game/

I am curious to know though, I’ve done some poking around as to what “external profile” is and what is the importance of this,


#20

Could this be because your project doesn’t have a default map setup?