Bull cow game compilation error

Running E:/UE_4.25/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project=“C:/Users/User/Desktop/BullCowGame-starter-kit/BullCowGame.uproject” -game -rocket -progress -log=“C:\Users\User\Desktop\BullCowGame-starter-kit/Saved/Logs/UnrealVersionSelector-2020.09.16-16.10.17.log”
Discovering modules, targets and source code for project…

ERROR: Could not find NetFxSDK install dir; this will prevent SwarmInterface from installing. Install a version of .NET Framework SDK at 4.6.0 or higher.

i even downloaded the required .NET Framework SDK but nothing happened. please help me. i am not able to go ahead of this course!!!

Also when i double click the bullcowgame.uproject it says "bullcowgame could not be compiled. try rebuilding from the source manually.

Please use these options when installing Visual Studio, it will install the required dependencies.

I did this. And, still, the problem persists. What should I do ?

I DO have this working. Now!

I’d like to pipe in as I just had this problem myself. @ Rachit_Vasudeva You may want to go to #5 in the list first. Everyone else, here are the list of things that I did.

  1. My Visual Studio Community 2019 installation had Visual Studio 2017 Build Tools installed. I uninstalled the 2017 Build Tools and installed the 2019 Build Tools. Go to Tools -> Get Tools and Extensions and check your version. I uninstalled it from there. I then searched Google for “visual studio build tools 2019” and found a Microsoft Download site for the updated 2019 version. Then I installed it. Ensure you also have at least the latest .NET SDK, which is 4.8, as talked about here in your own listing. Worth a try! Didn’t work for me.

  2. I next went into UE4’s Edit -> Editor Preferences. Under the General listing is Source Code. Open that and set the “Source Code Editor” option from “Visual Studio” to “Visual Studio 2019”, or the version most closely representing your installation. Restart UE4. Worth a try! Didn’t work for me.

  3. I then tried moving the location of the “BullCowGame-starter-kit” to the root of the drive I was working in. I had a crazy long directory structure with a couple special characters in it. I do believe this was contributing to my issues but this wasn’t enough. Worth a try! Didn’t work for me.

  4. Next I installed UE 4.22.3 from my 4.24.3. A complete replacement back to the old version. I found that the “BullCowGame.uproject” file was using 4.22. You can check it with a text editor or within VSCode. Worth a try! Didn’t work for me.

  5. I saw in one of the forum entries from SaintRock that he/she manually changed the “BullCowGame.uproject” file to match their version of the Unreal Engine. So I edited mine in a text editor. Saved it. THIS WORKED FOR ME!

Once the program actually compiled and opened UE4.22.3, I ran into the Error Message popup that is mentioned here. Just click on the “Clear” button in the bottom right-hand corner of the window. Go to File -> Save Current. Then close Unreal Engine and double-click the “BullCowGame.uproject” file to ensure it opens. This error message is mentioned in the video at about the 6:50 mark.

Thanks to everyone in the forums I did get my issue resolved. I believe that all of the things I did combined to resolve my problems but I would like to give a shout to SaintRock for Posting his solution. This forum thread is where I found most of the possible resolutions to Windows issues.

Laters…

i did so and it compiled!!!
thank you so muchhhh!!!

The file compiled as i did what daniel sir asked me to.
anyways, thank you so much for the efforts you made while giving me such a huge solution.
i appreciate it brother. cheers!!!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.