Totally lost on Setup and Installation

Nothing seems to be what is shown in the course…from clicking on “Clone” in gitlab. I installed the SSH version of Visual Studio Code. That wasn’t covered in the tutorial video. There was an HTTPS version also (for Windows 10). So I had to guess which one to click.

I got as far as "Allow an extension to open this URI? And it opened Visual Studio Code v 1.58.2 but there was no prompt as to where to save the file. Nor does the opening screen in Visual Studio Code look anything like the one in the video. Mine opens showing actual code…nothing that says “Getting Started” or anything else shown on the video.

There is nothing that says to create a repository location. So this is where I am stuck.

I hope the rest of this course will not have me constantly hunting around and guessing and having to open and search discussions to figure out what is going on.

I am a total beginner and this will be too daunting if the rest of the videos are like this one.

Please update the material.

1 Like

Welcome @ mwsheeler!

Personally I downloaded the zip file of gitlab and used the unzip folder like my new workspace because I don’t know what I had missed but for me too the “Clone” function don’t seams to work properly.


After I had to follow these instructions on this page to complete installation of Raylib compiler


Unable to see Raylib compiler in list

Don’t worry only this step caused me problems after that everything was perfect and easily understandable
Hope it help!

1 Like

Thanx Philx

I did the manual download and unzip. then I renamed the main folder to GameDev. All the contents I made sure followed the video. Luckily the Raylib compiler thingy did show up so I hope you are right and things will follow a little better in the subsequent video lessons.

Can’t thank you enough for your reply. Really helped me.

1 Like

It was a pleasure! Let me know if there is something else.
I really enjoy this course hope you will too!
All you need is confidence, focus and determination to succeed in this course like in all the others. I wish you all three.

1 Like

Thank you.

1 Like

@mwsheeler Try cloning in GitLab one more time, but choose VS Code (HTTPS). There is no need for an SSH connection just to have a clone to use. In the lecture the HTTPS case was chosen. It just went by very quickly.

This will go much more smoothly and you should be asked to choose a place where the cloned vscode-template folder will be inserted. Some folder that you want to do the project for this course is a good choice.

PS: I agree about daunting.

Orcmid I did as you suggested and told it to open in Visual Studio Code (HTTPS). Nothing came up to ask me where to put it. Windows Explorer did not open anything. A little window opened up after Visual Studio Code opened asking if I wanted to allow an extension something or other (I can’t remember exactly what it said. The screengrab below shows where it all ended up. Looks nothing like the screenshot in the tutorial. No “Clone Git Repository” under “Start”

I cannot reiterate how unnerving it is that this will not work. I haven’t tried to write that first hello program yet but I am afraid that will just be a repeat of yesterday and even if I go through all the generous suggestions that people posted to help me I will still end up with same Run Build Task…error that I kept getting yesterday after trying numerous changes.

I might have to swallow my course fee and just look elsewhere to learn C++ for games or just C++

I’m disappointed for you Michael. It is difficult to work through this more closely with you, although I do have screen captures of exactly what worked for me.

You should be within the 30-day refund window here. There are some other courses that introduce C/C++ programming, perhaps in a more-leisurely manner.

In 2016/17 I looked into a Learn C++ and Game Development with Unreal. That one has been remastered since. I think there are others. And there are many courses on C/C++ if you are willing to start there first.

I am a big fan of this course, in that the raylib approach is awesome. But many rough spots and keeping it all beginner-friendly is very challenging. I don’t have a good answer. This approach to using VS Code as if it were an Integrated Development Environment is a new experience for me. I seem to know just enough to be dangerous.

I bid you good fortune in however you proceed.

You have a good heart orcmid. And I am grateful for all you have put forward for me to try. I will not give up but I will look elsewhere also. I have been an illustrator for over 50 years and would like to create a level using unreal or unity where I can have characters travel throughout a ship I am building in Blender called the HMS Victory. Doesn’t have to be a game but more of an architectural walkthrough of a realistic ship, deck by deck so that anyone can have the visual experience of moving about it in 3D and interacting with the various parts of it. To learn about the tall ships of that period.

to quote, " I will not give up the ship!" Nor my quest to learn the programming to pull the project off.

Thanks again orcmid.

@mwsheeler Michael, I went back through the screen captures I had made when I did the VS Code Template step and I developed a step-by-step tutorial that shows how I worked my way through that part of the setup.

I don’t know if this is much help at this late date, but maybe it will help others not to be too deterred by this mysterious operation.

This is not exactly beginner lore, but if you get past it, the further journey should be easier and more rewarding. My impression is that raylib is beautifully done and a great way to make video presentations and two-D games like the side-scroller that is one of the projects in this class.

Raylib is unparalled in that it provides great capability without forcing us into an even more exotic game-development platform. I am eager to get to that point myself.


Did you shared this step-by-step tuto I would like to give it a try again!
I found it Thank you!

@mwsheeler you can certainly find other courses elsewhere but personally to have tried several of them, the GameDev courses are by far the best (this is my opinion) The steps called challenge are unique to Gamedev and make these courses much more educational, have led me to develop better habits faster and built self-confidence. The community is also very well developed and unique too! I made Unreal Engine C++ courses and really enjoy them all. After doing several of their courses I find the others really ordinary even my university courses that I paid a fortune.

Hi Michael,

This may be a little late and a dollar short for you but we are aware of difficulties students are having with installation/setup and are working on a simpler set of instructions.

Thank you for your patience.


I’m sorry about the confusion all. I didn’t explain the process very well.

I’ve re-recorded the Setup and Installation videos, as well as the setup videos for Axe Game, Dapper Dasher and the Classy Clash game as well. I’ve show all the steps that will get your code compiling.

Also, the VS Code template is now different, so you’ll need to download it again (I download it as a .zip in the video now).

And there’s a Raylib VS Code template for raylib projects and a VS Code template for plain C++ projects as of now.

The process is to download the .zip file, extract it, and simply open the workspace. You can do it by right-clicking on the main.code-workspace file and clicking Open with Code (if you enabled that feature when installing, which I’ve added to the installation video) or, if you don’t have that feature, simply open VS Code and go to File → Open Workspace and find the project’s main.code-workspace and open that.

You don’t need to Configure Default Build Task or anything. The .vscode and Makefile take care of everything. You can create a source file and start coding, or use the projects on the Gitlab page. Everything should compile just fine (compiling will create an .exe of the game) as well as Start Debugging and Run Without Debugging.

The videos are up on Udemy and should be up on the other platforms shortly.

Again, I’m very sorry for the frustration and things should work smoothly now.

1 Like

I have had far more success since following your new installation and setup video.

Thank you very much for that. I know it was an inconvenience.

It all worked for me except that my Terminal section disappears after hitting a key from my keyboard in that section. The Run Build Task shows it was successful.

So I opened a new Terminal and it allowed me to enter the “.\hello” and it ran the program fine.

So other than that little glitch of the Terminal text all disappearing I have finally gotten some success. Hopefully, I can find out why this small glitch happens but at least I know I can continue with the course.

Very grateful student here!!!

1 Like

Awesome, I’m very sorry about the previous issues. I’m happy it’s all working and it should be a smooth experience from here on out.

I’ve added a new comment to the video about the terminal, mentioning that you can open a new one as you did if it closes.

Thank you so much for being patient and as always, don’t hesitate with questions or concerns.



This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

Privacy & Terms