The client cannot join the server session

I reviewed the previous comments of those who had the same problems as me. But I don’t even understand how to solve this problem yet. I’ll start from the beginning. I’m using UE5.2, Windows10. I compile and run the project through Visual Studio development environment (as for me it is much easier and more reliable than through “Live Coding, UE5”). So when I start the project through Visual Studio, everything starts normally, the engine itself starts without problems. But when I click on the “create server” button . Visual Studio gives an error (probably critical because of the logic of the code itself).

I click “extend” and a session on the server is created and everything seems to be normal. Only on the client window when I want to join the server. Above it shows that the server is found but no game sessions are found and that’s it.

I commented everything in DefaultEngine, as discussed in the comments under this lecture, switched off stim and tested everything the same way “session not found”. I switched back on steam and uncommented in DefaultEngine and called on steam. I even thought that there may be a problem in the code. Because others even displayed the IP-address, but I do not. So I removed my code and replaced it with the one I found on GitHub. But it still does the same thing. So I don’t even know what to look at to solve this problem. As far as I understand it pops up for almost everyone, but it is solved differently.
I APOLOGISE, I FORGOT TO ADD THAT. That when I run just a project from the engine or from file.bat, the server session is created without problems. Even in the previous lectures when I launched via V.S. there were no problems either. Only since the 15th lesson this problem started.

However, I played with DefaultEngine a little bit and started the project via bat.file. Then Steam is displayed (it is not displayed through the engine). And it already runs a session, but writes that it can not find the server JoinCoopADv.

However, I played with DefaultEngine a little bit and started the project via bat.file. Then Steam is displayed (it is not displayed through the engine). And it already runs a session, but writes that it can not find the server JoinCoopADv.

I apologise I may have confused you with my corrections. But in brief the situation is this if you run through bat.file, the session is found and displays the name of the server to which should connect. Through IDE when creating a level on the server it gives an error about transition between client/server levels. And when searching for a session neither the session nor the server name is found.

It works from command line still?

This is pretty much what everyone sees.

Upload the zipped project folder here (deleting certain folders as stated on the page) and I’ll take a look.


You mean the bat.file? I’m already doing the archive

Basically yes, a batch file. It’s the way I usually test stuff because it is closer to the death thing.

Well yes quite normal I would say better shows itself than through the launch of UE. I just tested it a few minutes ago and this is what I got.

Ok, found the issue.
I still can’t run in the editor (which is normal as far as I’m concerned) but the issue is actually in the WBP_MainMenu blueprint

The Server Name has to match - so, on join it can’t find the server.

So, just right-click on the Create Server’s Server Name and promote to variable, then drag the pin into the Find Server’s Server Name and this will eliminate the duplicates

This is only temporary anyway but give this a try.

Thank you for your quick reply. I tried what you suggested but so far no result. I have tried through the engine itself and through the command line.

Tried running it again only now (VS). Now it shows the server name, but I can’t join it

Are you running 2 sessions and create a server with one?

Both have to be launched from the command line as well?

This worked perfectly for me and was able to join the game. I added -NOSTEAM to the run option to ensure steam is ignored.

Other than that, this comes down to local configuration as your code is correct and functioning.

I run the two sessions from the command line only.

The other two sessions are created automatically. I will try to add NOSTEAM now. Have you run the project through (V.S.)? Did you get a critical error when creating the server?

I don’t use visual studio at all. I have 2022 installed for the tool chain but use Rider as my editor of choice.

I also would never run the software via the editor and always test using poweshell when it comes to multiplayer at least.

So far no change, maybe I wrote something wrong in DEfaultEngen.ini?

Ah, no. OSS should be NULL but when you run from command line you add -NOSTEAM at the end and it blocks steam from being loaded. There’s an issue with steam still being used in 5.2 even with the Null subsystem is used and this prevents that from happening.

Where exactly am I supposed to write NOSTEAM or did I misunderstand you?)

I’ve just tested it twice, through the command line. I ran and my IP address was displayed, but it didn’t connect to the session. And the first time it was written in the path file NOSTEAM, but this time it was NULL. Only I can not understand why such adventures go with the test . When I run the test through the browser one result, through the command line another one…

I take it you’ve been busy. But here’s what I’ve got these past couple of days. One time I got it to work consistently, But then it went back to the way it was. Trying to join the server, writes my address, like everything is normal, but connection to the level does not happen. I removed the commenting symbol from the line (If using Sessions), and everything worked fine. But today everything started the same. The first time I start a session found, but started, closed the created level, opened a new one. On the one I tried to connect create a session, and on the new window connect immediately.

I can’t understand … if everyone says that in:




DefaultPlatformService=steam // here you need to write NULL to be able to connect (which I did).




If using Sessions// after commenting this once




Why is it , stable does not work !

Sorry, I have indeed been busy. This is what I use to run the tests from powershell. You’ll need to update the paths but something like this should work:

& 'D:\Epic Games\UE_5.2\Engine\Binaries\Win64\UnrealEditor.exe' "H:\Unreal\NewMultiplayer\CoopAdventure\CoopAdventure.uproject" -Game -WINDOWED -LOG -NOSTEAM -ResX=800 -ResY=600

No, it’s not, and it’s working weird. I added this under my path: -Game -WINDOWED -LOG -NOSTEAM -ResX=800 -ResY=600 and it started to start UE itself with the selection of the project, instead of starting it…or should it be!?

It needs the project. you still have to build external to this as it doesn’t build the code.
When I had a look at one of your projects from before, this is how I tested it and it worked just fine.

Look what I got. If I don’t run the engine, everything works fine through the command line. If the engine was started at least once there is a delay with connection and nothing happens, it was just described in a separate cmd window. But the problem is different. I downloaded the project and decided to test it as in the lesson, the result is the same and the same does not create a server session. In the messages you can see that everything is created and even on a separate PC you can see the server and it is connected to it, but the level map itself is not loaded.

Privacy & Terms