My Character walks into my capsule. How do I fix it?

My Character walks into my capsule rather than standing next to it.

It’s likely that the WeaponRange in the inspector has been set to zero. (This happens sometimes.) Once the value is set in the inspector, no matter what you change it to in the script, Unity will remember what was set in the inspector. This is because the field is serialized.
Take a look at your player in the inspector and check the weapon range.

No, it’s set to 2, is there any other way to fix this??

Ok nvr mind, setting it to 3.2 is perfect. Thank you for you help.

Regards:

-oakleaf15