Jittering on Tank Rotation/Elevation

Dear Udemy,

I understand there is a thread already with information in this issue at:

But I still have questions in regards of this procedure shall I just implement these solutions:

  • Why does Ben code and Unreal Editor procedures don’t create any jittering? I am very confused. Is it because it was developed in previous versions?
  • Are these issues addressed later on the tutorial?
  • If I implement this would I be compromising other upcoming lectures implementations? Because I feel I am stuck at this point, even though I am able to spawn projectile but again my turret is moving with this effect and just going back and forth

Dear Ben or Dan, I would highly appreciate some lights in regards this issue. 8 Days have passed and I have patiently waited.

Sorry I missed this, just tag me if I don’t respond within 24 hours; that way I get a notification.

  1. Different engine / Visual Studio version
  2. Where are you at now? Or did you stay at 44_BT?
  3. Could you show me a video of how yours is behaving? Or just send me your project.

Well I actually managed to solve part of the issue reading and reading the forums. I highly appreciate you guys are providing us with ideas, solutions and support in general. To answer your questions:

  1. Unreal Version: 4.22.3-7053642+++UE4+Release-4.22
    Xcode Version 11.0 (11A420a)

  2. Rigth now I am working in the Quit button at video 229.

  3. Sadly still not working. You can see its behaviour in this link:

I will upload everything into my GitHub this evening. I haven’t been able to push for this issue (Which I believe I will sort today):

This is my GitHub project

So I fixed the inverse aiming issues through the collision issues dealt on video 229 (Adding a Quit Button). But when trying fixing the Physics while loading the game through the MainMenu, even have followed the video, my AI tanks are flying all over the place.

On Unreal Engine Answers

they say

I’ve fixed it by setting the SimulatePhysics to false in the blueprint by default and adding this, physics are only enabled after the level is loaded

Sorry being this noob but where and how do I perform this?

Then I would assume they mean BeginPlay so you just get a node for the Tank and drag off of it and search for Simulate Physics.

I am very sorry Dan, I’m not sure if I am following. I actually disabled the Physics but same as the video the Tank was floating afterwards.

Then that sounds like you didn’t enable it BeginPlay

I am very sorry Dan, I performed all the suggested solutions. Still not managing to fix the Physics issue while loading the game from the Main Menu.

Shall I do this?

Suggested Fix

I admit I am a little bit worried since there is a comment there saying it eventually creates another issue later on.

Ooooh. I didn’t realise you meant from the main menu level.
However I found that just setting the static meshes in the constructor fixed that. No need to do the simulate physics stuff.

Do you mean while creating actual Track classes of each piece of the Tank solves it? (that means that would be solved further in the lectures, right?)
Thanks so much Dan for helping me get this clear.