GameDev TV main course site is super bad

Guys I don’t think this is normal, video courses you put on GameDev TV site are not working.

I paid fairly for them but it turns out I can’t use them - usually I use firefox daily to do any web related stuff (visit at least a hundred sites per day - 0 problems with any of them) , then I turn on your site to follow a course I paid for - nah… not working.

OKEY , WENT AHEAD AND DOWNLOADED CLEAN CROMIUM INSTALATION JUST FOR YOUR “fabulous” website so I can watch PAID course. but guess what, not even a FRESHLY UPDATED CLEAN INSTALATION OF CHROMIUM (without any addons, and with all permissions possible for your website) CAN’T RUN A VIDEO ON your game dev website.

Please fix this asap , or give me the option to transfer my PAID courses to UDEMY (that isn’t managed by you - THANK GOD - and works like a charm) or refund me in full for courses I paid for.

Screenshot above is how your website looks on clean chromium install. Truly unacceptable and I’m beyond mad about this.

1 Like

Videos have never been directly available here on, however, what most folks here do is upload their video(s) to YouTube or another video site (the name of which I can’t remember at the moment), and then just place a link to your video(s) here on GameDev.

That way everyone will be able to see them here on GameDev without issues.

1 Like

Works for me…

1 Like

This is likely a problem with either your ISP blocking certain websites/links, possibly based on region, or less likely but also possible some parental control setting doing the same, which is why it doesn’t load no matter which browser you use.
Nothing GameDev has any control over. The courses work fine for hundreds of people, you’re the outlier here so don’t get mad and ask for help/refund like a civilised person.

1 Like

just having a look at the courses page and checking with the team if there is anything untoward with course hosting service. ill get back asap

1 Like

Hi there, seem not all course have issues, f.e. doing “Make Online Games Using Unity’s NEW Multiplayer Framework” till yesterday without any problems but today only white screen with finished loading.

On the other hand course “Unity Turn Based Strategy: Intermediate C# Coding” seems to work quite normal.

Maybe with a lil bit less rage and more information you can find the troublemakers.

Kind regards

PS: just for the record, anybody paid for these courses, and udemy sometime has issues too

PPS: in my courses only the “Make Online Games Using Unity’s NEW Multiplayer Framework” has issues… seems to me only some have trouble


cheers for checking, does seem to be an issue with the hosting service. there was maintenance for them but that was yesterday. dont normally see any issues.

ive raised it with the team so hopefully get a resolution as quickly as possible

1 Like

Thanks for linking my issue.

These courses have blank white page and 422 status for me:
Blender Texture Painting: Create Stylized Models
UE5 Action Adventure (this for sure had a different style page)
Anime Character in Blender

Most of the courses still work fine.

1 Like

The HyperText Transfer Protocol ( HTTP ) 422 Unprocessable Content response status code indicates that the server understands the content type of the request entity, and the syntax of the request entity is correct, but it was unable to process the contained instructions. Warning: The client should not repeat this request without modification.

Do use adblock or other advertorial blocking service?
Or a VPN?

1 Like

i only get white screen without anything printed on it… no VPN in use … deactivated Blockers from Kaspersky completly but no change… seems to be server indicated

1 Like

Nothing wrong with my ISP , dunno how you’ve concluded that from the info provided here. It’s not a first time having trouble with their game dev tv site , it’s the ONLY site I need to step out of what’s normal for a website because privacy badger and few other addons break the game dev site that is full of trackers and cookies.

But just so no-one here jumps with the comment again “it’s because you use addons” , screenshot is from clean chromium install without any addons

No VPN or add blocker. OboShape said there was an issue with the hosting service.

{"code":"course_not_found","message":"Course not found"}

Cloudflare says all their systems are operational. Maybe during the maintenance they modified their API. I’m sure the GameDevTv team will figure it out, and I’ll check back in latter. Good luck guys!

1 Like

Maybe I was wrong about the ISP, though I’m not 100% convinced but seeing the other responses there may be something else going on. I still don’t understand why you are so mad. If you’re unhappy with the service and you have courses on other sites why not just request a refund here and be done with it? If you want to raise awareness of an issue with the site you can still do it calmly. What’s the point of getting all worked up over this.


that looks like its all back up and running now, seems to have been a temporary issue across the board with the courses hosting service with some of the courses.

thank you for your patience and apologies again.

I understand students frustrations if time was set aside for learning and something untoward happens, unfortunately there are some things that are outwith our direct control but normally there’s none or very few unscheduled outages/downtime.

all I can do is apologise for the disruptions


Appreciate you trying man but unfortunately, still same…

Is there a way to transfer those courses to Udemy ? I apologize for my act today but I rarely find any time for this and everytime I do , it’s always something with gamedevTV website. I really don’t know what else can I do here.

1 Like

If you have mobile data on your phone can you try to see if the video loads there maybe?

1 Like

Strange,seems to be OK from my end.

We used to have a migrator tool a while ago but now if you email and ask if courses can be moved across.
This is dependent as well if the courses are available on udemy as well.


Hi Guys,

I am sorry to hear that some students are having issues accessing our courses on our site.
We currently use teachable as our backend so we work with them to diagnose issues with the site.
It seems to be regional rather than VPN related and it may be that it is still ongoing fixes at teachable’s end and servers that you are being redirected to.
Clearing the cache can often solve some issues but may not help in this case.

We are working on updating to our own platform but as you can imagine creating our own platform takes time and a lot of work but we are very excited for when we are able to release this to you guys.

As Oboshape has mentioned you can contact our support sales team and they will be happy to transfer the courses you have that are not working to Udemy so you can get back to your learning :slight_smile:

Once again apologies for the inconvenience and we will keep working to get this resolved and make every improvement to our site to ensure a good learning experience all round.

Marc Carlyon Support Leader


just for the record, the “normal” issues have been solved for my courses so i can access anything again now.

@tomek320 - i fully understand your feeling for trying to find time for learning and when you have it there is an issue of any kind

@Marc_Carlyon - as an update is possible to transfer my udemy course to this page too? I know it has been done when i finished the RPG courses on udemy an got them here but i have unfinished courses on udemy to and would like to use your plattform in the future cause my udemy account is only given by the company i work for and is only open till they drop it

Hi Sethreus,

It certainly is possible to transfer your courses from Udemy and its even easier with our migration tool (Unfortunately it does not work in the other direction)

Just follow the instructions on the link below and it will message you links to get your udemy courses here on our platform.

Hope this helps and glad to hear that its working for you.


Privacy & Terms