Doesn't work for some reason!


#1

So I made and WebGL build and zipped the file (with the index.html in it) but for some reason when I give the file to share my game it just stops at the processing part and I have no idea why and the game is 16mb can someone please help me.


#2

I’m having the same issue.

Repro Steps:

  1. Create a WebGL Build
  2. Zip the project
  3. Go to http://www.sharemygame.com/
  4. Select the zip folder for upload.

Experienced Behaviour
You see an “Uploading” progress bar which fills from 0-100%
The text then switches to “Processing”
I left it to process for an hour in Chrome but it never completed.
I tried again and left this second attempt overnight, but it was still processing in the morning.
I tried in Firefox and the issue persisted.

Expected Behaviour:
The “Processing” would finish and I would have a URL for the game.
I’ve tried in Chrome and Firefox, but it just sits at Processing. The zip file is well under 100MB.

File Size
Unzipped: 7.3MB
Zipped: 6.6MB

*edited for spelling/clarity


#3

Hi,

What tool do you use for zipping your build files?

Which level in the folder structure are you zipping, the parent folder for your build files, or just the build files?

Does your project name contain any spaces or special characters? These can often be a problem, if so, try renaming the project and then rebuild.


My Block Breaker game: Space Hero
#4

Hey Rob,

I’m using 7zip to zip the folder. I’m zipping the parent folder I believe, which contains the index.html, template data and all the build files.

The folder name didn’t have spaces, but it did have a “_” so I tried taking that out and rebuilding but I still have the same issue when uploading.


#5

Hi,

Use Winzip instead of 7zip, if you using Windows, use the built in compression tool, I think this will resolve your issue.


#6

Thanks Rob!

I downloaded Winzip and used that instead of 7zip, and it worked.

Out of curiosity, do you know why?

Thanks for your help :slight_smile:


#7

I can only assume there is a difference in the built file, on the server I suspect a library is being used for the unzipping functionality which is perhaps incompatible with the 7Zip format. Which OS are you using out of interest?

Possibly something of use here:

“The only issue with programs like 7-ZIP and WinRAR, both of which did the best in compression, is that they use proprietary formats that are not fully supported on other systems.”

@sampattuzzi may be able to shed some light on it? Sam, perhaps one for the common issues?


#8

7zip isn’t a .zip file, is it?


#9

That maybe a case of symantics… Strictly speaking, perhaps not, but when asked to zip files, people will often use their tool of preference… I had a .rar sent to me the other day - of all things! :smiley:


#10

Ah, okay.


#11

I think 7zip does create a zip file if you ask it to…?

I also downloaded winzip to try too

Both zips got stuck just showing processing - tried on Firefox and IE

Will try again tomorrow…


#12

Not sure that 7Zip uses the standard zip format, I don’t believe, same as WinRar - I think this is the main difference/issue - and of course because the site just says “Zip” file its kinda open to interpretation with regards to that which is what creates a bit of a confusion.

Supporting additional formats would possibly be the solution here I think.


#13

The 7zip zip file shows as a winzip file in explorer now I have winzip downloaded

FYI after a reboot both zip files uploaded successfully…


#14

That’s handy to know, thank you Eddie. For reference, for anyone else who stumbles across this topic, did you change any settings in 7Zip for the .zip format at all, or just using all default settings?