Cube dude beach ready

I created this scene to see if I could improve my original Cube Dude “The Pool” animation. Seen here Full animation movie "Stress Ball - The Pool"

Rendering this single frame takes about 10 min. And my animation is about 2700 frames. Which means more then 19 days of continuous rendering. For 90 seconds of movie time. So I cancel this project for now.

The composition of this frame is not so interesting. But I applied the following techniques:

  • Beach sand in front are sand particles (150.000).
  • Sand in the back is just bitmap plus normal map, avoiding sand particles which uses a lot of memory.
  • Added an oval vignette (image corners darker).
  • Coconut hairs about 2000.
  • Added normal maps to Duck and Ball to mimic plastic seams and dents (but quality is low). Trying to keep mesh size low.
  • Red-white towel baked from a cloth physics simulation.
  • Slight camera blur.
  • Render samples 96. Could be higher to improve the dive glass reflection and transparency. But tried to keep render times low.

As always, happy render times.


This is really good man, could easily see a “Minion” in this shot! xD

Great idea on the Sand, it’s really hard to notice the difference from the front to the background sand.

But why not a Green Coconut? A Dry Coconut is not suitable for drinking on the beach because well… it’s dry :smile:

About the render time, have you tried with Eevee? :smiley:
Ofc may look somewhat different, but possibly It will still look good enough

Now you say it, using Eevee, that’s really a good idea.
I didn’t start with Blender 2.8 because of all the UI changes and first version.
But you are right, I’ll think about an Eevee test run.

A reply to my self :wink:

I imported the scene unchanged into Blender 2.8 (scene was made with 2.7.9). No problems occurred, everything looked okay.

So rendering with Blender Cycles 2.8 was about 50% faster then in 2.7.9. But my ground plane, the base for particles (sand) was missing (I think hide parent is switched off?)

Rendering in Blender Eevee was funny. The system was busy a minute or so, then suddenly the image was shown. Clock 1.21 min. But a lot of stuff is missing.

1 Like

if you go to the second tab in the properties panel you will find a number of render options that need to be turned on (i.e.: screen-space reflections, ambient occlusion, depth of field, etc.). It’s also worth noting that Eevee needs about half the lighting that Cycle needs and that there are a number of nodes that don’t work the same.


Probably because of the materials too, sometimes you have to change them to make them appear. Add a new Material Output. I had a problem like this where the materials were not behaving correctly because the output node from the 2.8 is different from the one used in 2.79.

Also look the Collections(new concept for layers) possibily some are not showing up. (although never had this problem)

With Eevee you don’t need to increase the Samples too much (since you don’t have fireflies), keep that in mind. I don’t know how much samples you set to render but if you gone high like cycles needs more than 100 you can turn this back down to like 32 and going up from there…

You can try the file I posted here BMW Test in Blender 2.8 - Cycles and Eevee
And test 32,100, 200, 300,1000 the difference is so subtle that you wonder if you need all the samples


Privacy & Terms