Connecting Works, Can't Go To Level


As someone pointed out below, if your DefaultPlatformService is NULL in the defaultEngine.ini, make sure you are logged out of your Steam client.

Yeah I am logged out. I tried with both Steam and NULL. using two open clients to try NULL and using one of my friends connecting through steam. Both times able to show that there was a connection made and joined but not brought to server.

looking through logs, I have these errors:


Are you using UE5. 3 by any chance?

Anyway, if you upload your project folder here, zipped after deleting the binaries and intermediate folders, I’ll take a look for you.

Upload here: https://gdev.tv/projectupload

Let me know when it is uploaded. It may take some time but I’ll get back to you.

I’m seeing a lot of this at the moment and it is usually 5.3 issues. 5.2 seems to be fairly stable and works.

Using Unreal 5.2.1, my entire file seems to have gotten corrupted to the point where I can no longer even open my maps or character BPs after trying to remake the EngineDefault.init. Going to have to restart the section and see if its working. Will upload there if I have the same issue

That is so unfortunate. Let me know how you get on once you’re back to the same point.

Got back to it, still having the same issue. Will Upload to the link

Sorry for the delay. Have it now. It will be later today before I get a look at it, possibly in the evening.

Ok, I am able to open just fine. I deleted the binaries and Intermediate folder, also the vs folder before opening the uproject. The project I see is not based on the course (aside from the subsystem)

This points to an issue on your machine rather than your project. It could be a virus scanner or other tool that is causing issues. It could also be related to where you’ve saved the project - UE insists on standard ascii characters for example in the path, and it should never be located anywhere where it gets synced to the cloud automatically like OneDrive.

Aside from that, what you’ve got here is fine and works.

Strange, I have had the issue testing it on two different machines. I wonder what’s causing that.

And im still following the project, including the next main game section, just converted to first person as I want to expand it that way.

Thanks for the help.

Just curious but have you tested using the command-line? I saw another student with exactly the same issue but running from the command-line fixed the issue.

I use the following (paths will be different) and you can run it twice to open 2 windows for testing from powershell.

 & 'D:\Epic Games\UE_5.2\Engine\Binaries\Win64\UnrealEditor.exe' "H:\Unreal\NewMultiplayer\CoopAdventure-Test\CoopAdventure.uproject" -Game -WINDOWED -LOG -NOSTEAM

I have accidentally upgraded to 5.3 for my project and it seems there is no simple way to downgrade to 5.2

When I try connect to a lan game using 2 instances on the same machine I always get 0 instances found.

Is there somewhere an overview of things to look for or troubleshoot over for 5.3 connectivity issues?

5.3 works but usually you either use command-line or packaged builds.

For UE5.3 use “-NOSTEAM” as an additional parameter in the batch file to be able to connect to the server locally. Likely this is an issue if you have STEAM running on your local machine, like me, even if you use the Null subsystem.

Hi there, i got a similar problem. Somehow I can not find a LAN session.
Using 5.3 and Linux.

Do I have to also comment these out when using NULL ?

[OnlineSubsystemSteam]
bEnabled=true
SteamDevAppId=480

;If using Sessions
bInitServerOnClient=true

@beegeedee Could you elaborate on which version of a packaged build would work?
Right now i am using the command -line with

/../MPAdventure.uproject -game -ResX960 -ResY 540 -log -WINDOWED -NOSTEAM

Have not finished the complete Lecture I am still at the discovery part. I am not 100% sure cause building takes a while, but maybe I could find a session with STEAM from 2 diffrent systems.

:thinking:

The command line normally needs -NOSTEAM added to it as well for lan play to work. 5.3 seems to have issues but saying that, I encountered the same issues in 5.2 as well, in the editor anyway

Also, when launching from command line you need to start with the Unreal Editor and the rest are parameters to the editor itself.

Someone also suggested that they got it working by using the option to run as standalone game inside the editor and this worked too. I suspect it is basically launching command line sessions.

Lastly,when I was running through this course, I hit an issue here, for steam anyway, and it was because I forgot to enable the steam OSS from plugins. It worked packaged which was strange.

Give these a try and let me know how you get on.

Privacy & Terms