Be the first to post for 'Unreal Development Environment'!

I do. Everything on my computer should be 64-bit. Thanks for the response, going to continue trying to fix it today.

Will update when fixed,


Everything is fixed and working as intended. Thanks to anyone who helped.

Everything is installed and working correctly.

Using Unreal Development Environment 4.14.1 for the course.

Is there an issue with using the newer versions of Unreal Engine as opposed to 4.10 which is the one used in the course (depricated libraries or similar stuff)

I tried a tutorial written for 4.10 when 4.14 was first released - There is a slight difference in the way you bind to assets and move them about (called “Pilot Mode” in 4.14 and accessible with the R-Click menu), but it’s pretty much the same (as far as I went, which wasn’t very far as I had a creaky old laptop at the time).

I have a quick question. I have some spare money and I’ve been wandering should I replace some parts in my PC with newer ones for better performance? I could probably replace GPU or CPU, and add another 8GB of RAM. Here’s my system:

  • CPU: AMD FX-8320
  • GPU: AMD R9 270X 2GB
  • RAM: 2x4GB 1866MHz

I’m a bit worried if my GPU won’t have somewhat smooth performance. I could probably upgrade it to RX 480 8GB + 16GB RAM , or just get a 1060, maybe a 1070, but that would be a big stretch really.

Since I’m redoing the course over I decided to use Unreal Engine 4.15.1. I went ahead and installed it since the website said it had come out. I had no problems installing it. Everything hunky-dory.

I have a question for individuals who have completed this course or anyone with something to say. I noticed a link in the resources of the course that mentioned using QtCreator with the Unreal Engine. The instructions mention the need for Visual studio 2013. As the course is recommending the use of Visual Studio 2017, has anyone had any issues using the QtCreator with the newer version of Visual Studio?

I’m have the same question, & do we have to make any changes in default list of components/tools that are going to be installed?

I’m from the stubborn group :slight_smile:
I’m using CLion instead of Xcode. Pretty happy camper for the moment.

There is a great post on the CLion blog for UE4 :

Painless process for the most part. The initial indexing takes awhile and it’s a good idea to bump the memory for the IDE. If you are familiar with JetBrains products (like Android Studio), you will feel right at home.

When I have the time, I will try the setup on Linux ( I still haven’t chosen what distro to use my spare SSD for :smiley: ). My aim is to end up with a nice cross-platform environment and learn a few new things along the way. Fingers crossed for every thing to go as planned.

Looking forward to go through the course :slight_smile:

I was having trouble downloading the engine itself. I got the launcher up and running just fine. It turns out that there is a big difference between Program Files/ and Program Files(x86)/ that’s pretty important. So… now I’m embarrassed. Let’s see what else I can go muck up :\

What are the benefits of using the QT creator linked to in the side bar of the video?

I currently use an Acer laptop. nothing special or particularly high end. Would you recommend me to invest in something new in order to be able to fully get the experience I need from this course?:slight_smile:

Hi everyone its Sergio. I was wondering if we needed to download some of the stuff on the links like the QTcreater or snagit. Is it required for the learning experience? Have a good day everyone.

You would need to put the specs of the laptop so people know what you currently have to work with but generally the more demanding the game your making, the beefier the rig you’ll need.

Hi everyone! I’m having an issue I have no idea how to approach. I have Visual Studio 2017 installed and working on my computer, but also Visual Studio 2013 and 2015. I was just about to start my first project on UE4 (4.17.1) when I got an error in that process. In the error message, I do have an option to open with Visual Studio, where I did select Visual Studio 2017 to run. But I do not get the UE4 environment showing up. Instead, just files in VS.

The error message is: ERROR: UBT ERROR: Failed to produce item: C:\Users\Thiago\Documents\Unreal Projects\Projeto013\Binaries\Win64\UE4Editor-Projeto013.dll

Can anyone help me with this? :’(

I’ve used VS 2017 with (minor) problems in Unreal. To do this I followed a procedure like this:

In Project Settings, find the default IDE/Compiler (I think it is under Platforms/Windows, but try the search function) and make sure it is set to VS 2017. Also in Editor Settings, in the Source Code setting, make sure the compiler is set to VS 2017. Then exit the UE4 editor and restart it and reload the project–this step appears to be necessary. Next, I think it’s in the file menu of the main editor window, there is an item to recreate the Visual Studio project, so do that. Then, once again, exit the UE4 editor and restart it with the project. Then, finally, choose the “open in visual studio” item.

However…sometimes the project doesn’t come up even after all this. So, from within Visual Studio, open the solution file (you may only need to do this the first time). It is in the project directory and looks like (nameofproject).sln.

After all this, compile. To be absolutely sure, compile within VS first (F7 key does that). If there are errors, sometimes they are spurious—so if there are errors, compile in the UE4 editor with the Compile button. This time, there should not be errors. But I always try compiling from VS first. The two ways of compiling are supposed to be equivalent, but in practice, there are some differences.

Alternatively, use VS 2015 instead which UE4 supports without (most of) these bugs.

Other things to try if none of this works: use UE4 4.16 instead of 4.17 (at least till 4.17.2 (with lots of bugs promised to be fixed) comes out, expected within a few days), since 4.17.1 still has a ton of bugs. (I myself continue to use 4.17.1 and just deal with the bugs).

Thank you very much for your advice. Still, I think it wasn’t a Visual Studio problem. This is what I did and what actually solved my problem:

  • I installed a previous version of Unreal (4.16.3 if I’m not mistaken). Nothing changed;
  • I uninstalled the Visual Studio 2013 and tried to open Unreal’s environment. No changes happened;
  • I also uninstalled Visual Studio 2015 but still got the same error;
  • Then I reinstalled Visual Studio 2015 and uninstalled Visual Studio 2017, following some instructions to how to set VC15 for Unreal. Still got the same error (all those are attempts with versions 4.17 AND 4.16);
  • I decided to follow again all the instructions of the Unreal course, uninstalling VC15 and reinstalling VC17;

What appears to have solved the problem:

  • Making sure I did everything right, just as when I got the problem, I tried to open Unreal through VC17. Then I saw something like “Visual Studio Android for Unreal” and I did install that.
  • By that time I had removed Unreal versions 4.17 and 4.16 and installed the 4.15.3 version on my computer.

I’m not sure if the first or the second attempt or neither of those solved the problem. But I hope I could help anyone that had the same problem as I did, which cost me a lot of time looking for a solution in a lot of forums. Also, their solutions where difficult to implement and I did not get a positive result. They are almost all unfortunately outdated.

hi i am very glad to be here, i am a Chinese and i am kind of worry about my awful English spelling, i am not a newbie of programming but you can also treat me as a newbie of programming, because i have been learning computer programming language many years yet i still cannot do it in the way like a real developer due to my current job is for maintaining the computer networks and hardware and lack of time to deal with many more other aspects, this udemy online course gives me a fantastic chance that i can do it the fun way,btw, i am a super fan of video game, so it is so much fun to be here, downloading the unreal engine now, i have chosen version 4.10.4 in which it is not a nearest version but somehow this is the only version i can process the downloading, maybe i am living in China and the internet connection is quite bad in between my home and the server. Anyway, i am very excited about this course :slight_smile:

Privacy & Terms