Alt R and Alt Z not working in blender

Hey there,

as the headline suggests you might run into the bug that the alt R and/or alt Z key might not be working for you in blender. It occurred when I tried to clear the rotation and toggle x ray mode while in the layout tab. For most of you the bug will probably be resolved when disabling the Nvidia InGame Overlay or rebinding the nvidia hotkeys as described in this community post already:

But it did not work for me. I digged a bit and found out that I also had AMD Adrenaline installed for my CPU, which similar to Nvidia uses these hotkeys for its purposes and has priority over blender. This means that even when you disable the NVidia InGame Overlay or rebind its hotkeys, alt r and alt z will still not be working in blender, as the next highest priority, in this case amd adrenaline, will consume the hotkeys.

You can see it in your task manager and programs here:

For testing purposes you can delete the AMD Software task in the task manager and then try in blender if the hot keys alt z and alt r will work for you, which they immediately did for me. Now I couldnt run Adrenaline, because it will just abort, telling me my graphics card is not compatible for the AMD Graphics Drivers.

Now as to how to fix this: I first just went ahead and deinstalled the AMD Software from my computer. I am running an AMD CPU and a Nvidia Graphics card so I thought this wouldnt cause any problems, but it does. After uninstalling the AMD Software I had no sound on my computer anymore (using AUX cable with sound boxes, bluetooth headphones still worked fine).

Still, I needed to get rid of the overlay. Well, turns out you can manually install the drivers for your cpu with minimal settings, so the ingame overlay of AMD wont get installed on your pc. Simply google your amd CPU and drivers to get to the AMD drivers page. For me it was this one here: which i got to by searching “AMD Ryzen 7950x drivers”.

Then I went ahead and chose auto detect and install:

After downloading the installer and running it you can choose this option here:

As the question mark tooltip will tell you, this will install AMD Software and drivers for your chipset again, but skip the overlay things. Now if you reboot your PC alt R and alt Z should keep working in your blender just as intended.

Bear in mind that I uninstalled the AMD Adrenaline Software completely before reinstalling it with the steps described. I dont know if this step is needed though. Maybe reinstalling the AMD drivers with minimal settings will remove the full installation before, but if you want to be safe uninstall it first, then follow my steps as described above.

I specifically bought an NVidia Graphics Card to avoid AMD driver troubles and better performance for blender but here we go again. Guess for my next build i will opt for an intel cpu again. I know you can fix this for AMD cpus, but I never had such issues with intel in the first place.


Wow complicated and daunting. Well done sorting it out and thanks for the explanation that I am sure some others will need and be grateful for.

I do find it odd that NVidia and or AMD go about commandeering shortcuts so they are not available to every other programme. Seems crazy to me as their stuff is probably never used by anyone bar specialists. Blender cannot be the only programme to want to use such shortcuts itself?


thanks! Well I think the problem is that they need to assign priority over their hotkeys or else the game or program you run will consume them, hindering you to turn on their overlay and so on. The problems I have is firstly, as youve already mentioned, alt z and alt r are likely hotkeys of other programs and thus will cause problems for your users down the line who are not gaming. Secondly, you dont get any visual feedback as to what went wrong. Now if you press alt z or alt r and the nvidia overlay turns on you atleast know whats happening and what to look into, but in this case with AMD the AMD Software Adrenaline will consume the hotkey and fail to open the overlay and worse even, not even display an error message. So the end result is that nothing happens. Thats what makes this really bad. Several people already reported this to AMD but I dont expect any changes, atleast not in the near future, so I atleast wanted to have this Thread in the community for others to get help in case they run into the same error

1 Like

Simple solutions must exist, these overlays could only be started by the start menu or something. Or a much longer string of shortcut letters/numbers making the possible conflict much rarer. Or even have a state of OFF and only get turned on by a game player that may want to use them, and knows they need to turn them off again after a session.

1 Like

Yeah, I mean I totally agree with you. I certainly hope Nvidia and AMD tend to their non gaming customers by making the changes you mentioned or atleast make it clear (by visual feedback) whats happening. Letting it be like this is just straight up bad

1 Like

Thank you very much! You’re my lifesaver! :blush:

I just encountered the same issue. I tried for a while and found that many ALT and SHIFT shortcuts suddenly stopped working. It was completely baffling! I was busy with work and kept searching for the problem, getting frustrated.

I never expected it was caused by the recently updated AMD CPU driver ! Fortunately, I stumbled upon someone like you on the internet—a genius! I even registered an account just to thank you! :raised_hands:

1 Like

Im really glad I could help you! Best of luck with your Blender Journey continuing forward :slight_smile:

Privacy & Terms