Wtf why is pawn falling in the dark?

I try to connect like the chapter said. it connects successfully in the console but this is what I see in the client.


Hi can you provide more details please. I assume you’ve started with the third person template. Can you confirm the version of unreal that you are using?

I fixed it, the map path cannot work with \ I switched to / character and worked. but server does not spawn a pawn like in the video. that was weird. I had to create 2 clients to test it.

1 Like

Do you have a spawn point in the map?

The reason / is used is because it’s not a file path and also Linux and Mac users also use / as default so they did this for consistency

I mean clients pawns spawn normaly, only server does not have pawn. at first I though that it was not connected but I saw in the logs that someone joined. so after that I created another client and I saw two pawns. so I realized that server was not creating pawn. I did not create anything I was just using thirdperson example.

Without the project/code I can’t really say why that is.
I would hazard a guess that something has been missed. Which lecture are you on specifically?

I would suggest you review the code against end of lecture to be sure you’ve not missed anything.

there is no code, just created thirdperson project and doing the command stuff from windows console. (cmd) as described in the course.

Are you using UE 5x or 4.x?


Ok. I’ll investigate further. For a long time I avoided 5.1 because it was really buggy… Still is to be honest but they corrected performance issues which made it usable at least.

1 Like

Ok, Set up a new 5.1 project. I Noticed that when I first set up the project and started it had no players showing in one window - I am assuming this is what you are seeing?

There’s a little step that refers top 4.25 or later that you have to perform - I had to watch the video “Connecting 2 Players” again to solve this.

Next to the play button there’s the 3-dot menu where you set number of players to 2. You also have to access the Net Mode Menu Option and set to Play as Listen Server. If you miss this, it won’t work as expected.

Give this a try and see if this solves your problem.

Often looking over past videos helps with this situation.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

Privacy & Terms