Wire sphere Gizmo not clipping to the terrain in Game view

I’ve got a small issue with the gizmos in the Game view. In the Scene view the wire sphere gizmo clips at the terrain. In the Game view it doesn’t which makes it a bit harder to interpret where the sphere is. The only thing I can see in the docs that seems related is 3D icons, and that’s checked in both Scene and Game views. Not a big deal, but if somebody knows what I’ve done to get gizmo clipping turned off in the Game view, please let me know.

Got the same problem. I didn’t find how to fix it. If anyone else get the same issue, I’de be interrested as well.
Thanks

+1 after almost two years.