Why use "waypointIndex <= waypoints.Count - 1"?

Why not just use?

if (waypointIndex < waypoints.Count)
{

    }

Hi Joao,

That’s a good question. I assume that Rick wanted to emphasise what we are doing here. As for me, I would prefer your solution. In the end, it’s a matter of personal preference, though. Use what you prefer. :slight_smile:


See also: