Visual Studio Code no auto completion

Hi ! I’m following the courses about how to learn unity and C# in 2D video game. I’m French btw, so, if my grammar seems a little weird, I’m doing my best ^^

When I’m using Visual Studio Code, I can’t get the auto-completion, I mean, when I write something, there are no suggestions of code to help me. Is somebody can help me please ?
Thanks in advance. (Great lessons)

Hi Misha,

Welcome to our community! :slight_smile:

Please follow the instruction on this website and make sure all required extensions are installed: https://code.visualstudio.com/docs/other/unity

If the issue persists, please check the console of VS Code (not Unity!). If the .NET Framework 4.7.1 (Developer Pack) is mentioned there, download and install it from the official Microsoft website. Here is the link: https://dotnet.microsoft.com/download/dotnet-framework/net471

Did this help you solve the problem?

If not, install and use Visual Studio (Community Edition). For some students, VS Code simply does not work well. Maybe due to a problem with Unity, some update or whatever.

  1. Download VS and follow this instruction.
  2. Select VS as your External Script Editor in Unity (Edit > Preferences > External Tools).
  3. Install the “Visual Studio Editor” package in the Package Manager.

That should work.


See also:

Hi Nina, Thanks for your answer, it’s very clear. I’m going to try what you advised me to do, and I’ll come back to tell you if it’s working for me :slight_smile:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.