Visual Studio Code - Lightbulb/Intellisense not working

Hello, I can’t seem to get this lightbulb/IntelliSense to work in VS Code (version 1.55.2). I have installed the C# extension 1.23.11. Has anyone experienced this issue and found a solution? When looking in the defaultSettings.json it has all the standard settings.

Hi Alexu,

Welcome to our community! :slight_smile:

Please follow the instruction on this website and make sure all required extensions are installed.

Hi Nina

I installed the additional extensions, but it still doesn’t seem to working. The lightbulb doesn’t appear for example.

In the lecture we see this happening:

When we create the same code this shows:

My daughter and I are absolute beginners, so sorry for the basic questions :slight_smile:

No worries. Getting things installed and working can be quite challenging, which is the reason why programmers and game developers are a bit reluctant when it comes to updating things. Maybe you’ve already heard about “never change a running system”.

Here are three more ideas:

  1. Is Visual Studio selected as your External Script Editor in Unity (Edit > Preferences > External Tools)?
  2. Depending on your version of Unity, go to Window > Package Manager. Is the “Visual Studio Code Editor” package installed? If not, install it.
  3. Check the console of VS Code. Are there any error messages? A typical message says something about a missing .NET Framework 4.7.1. If that’s the case, install the .NET Framework 4.7.1 (Developer). Do not install any other or newer version.

Hi Nina. The External Script Editor wasn’t selected. It’s solved. Thank you so much for your help.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms