Visual Studio Code Intellisense and Parsing is Really SLOW FIX

Hey guys, I just want to share my solution to the above mentioned problem.
I faced this problem few months ago and asked for any fix in community - Link to the Question
I could not find a solution.
So, I started using Rider for Unreal Engine(which has been a great experience). But still wanted to use VS Code cuz I use it for other stuff apart from UE4.

So, I found this solution from a python intellisense issue discussion. which when tried worked for Unreal C++

So to Fix the problem →

  1. Edit Quick Suggestion Setting in VSCode

    Open the setting.json and the following code
  "editor.quickSuggestions": {
    "other": true,
    "comments": true,
    "strings": true
  },
  "editor.quickSuggestionsDelay": 10,

to the end of file like this
image

  1. Next change the Microsoft C++ Extension Intellisense Engine to Tag Parser
    like this

this will remove Intellisense based on context but will give fast code completion.

This should hopefully fix all your Intellisense issues like late loading of suggestions, parsing taking long time, etc.

Thank You

NOTE : This fix works in UE 5 also

3 Likes

Weird. Only comments and strings should be non-default from this. Can’t imagine that doing much unless for some reason its not working as their official page suggests or for some reason it didn’t get set. IntelliSense in Visual Studio Code

The settings shown below are the default settings.
...
"editor.quickSuggestions": {
    "other": true,
    "comments": false,
    "strings": false
}
...
"editor.quickSuggestionsDelay": 10,
1 Like

HELPS A LOT, Thanks Pal.

Tag parser on Intellisense Engine it great even if it’s give you a fuzzy mom-context aware, but you can easly find what you are looking for.

:metal: :clap:

Made my day.
I was so irritated with the slow suggestions. It goes to “Loading” each time I make any changes.
Now after your suggested changes, it works so good as I need.
Thank you so much.

Thank you soooooooo much!! This is really helpful!!!