I ran into an error on my Set Mover function on the secret wall so I tried closing the editor and compiled the code via vscode and when I opened the editor all my C++ components got removed from everything. so I had to re add the grabber and trigger and mover, and now I’m getting the "Grabber Requires a “UPhysicsHandleComponent” error and I can figure out what that meant again. I’m still able to pick up the statue but nothing happens when I place it into the secret wall.
I’ve disabled live coding ages ago


Have you seen the Live Coding Issues lecture? Did you compile with Unreal closed?

Yes I have, I disabled live coding a while back during the obstacle course. i compiled in unreal and ran in an error so i decided to close the editor and build from vscode, and when i reopened unreal all the components were unattached from the actors and what not.

Could you show what task you are using? It’s possible you’re using the wrong one.

By Task I assume you mean the build task in vscode, I used CryptRaiderEditor Win64 Development Build.

Yes, would you mind showing the output of using the Rebuild one?

did you want the Terminal Output on vscode or just the result of using the rebuild? I tried using the rebuild one (CryptRaiderEditor Win64 Development Rebuild) and nothing seems to have changed, i still get the Grabber Requires a UPhysicsHandleComponent Error message.

The output

Heres the Terminal Output: Output - Pastebin.com

That shows that you aren’t using the editor version.

 Executing task [...] CryptRaider Win64 Development

If you did it would say

 Executing task [...] CryptRaiderEditor Win64 Development

So I Tried using the Correct one this time and the result is still the same: * Executing task in folder CryptRaider: Engine\Build\BatchFiles\Clean.bat Crypt - Pastebin.com

I note that you have your project in OneDrive. It’s been a source of problems in the past so could you try with it outside of there?

I don’t use OneDrive or have it activated so I don’t know why its using it. When I tried moving my unreal projects folder out of OneDrive and onto my desktop or an other hard drive it would give me errors on all the #include lines and the build would not complete. * Executing task in folder CryptRaider: Engine\Build\BatchFiles\Clean.bat Crypt - Pastebin.com

After moving it did you refresh the project files (by right clicking the .uproject and selecting generate project files). Also does deleting the Binaries and Intermediate folder before rebuilding help?

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

Privacy & Terms