Unreal Engine Project doesnt compile

When I try to compile i always get this build failed log.

---------- Creating patch ----------
Running C:\Program Files\Epic Games\UE_5.1\Engine\Build\BatchFiles\Build.bat -Target=“UnrealLearningKitEditor Win64 Development -Project=”“C:/Users/Tom/Documents/Unreal Engine 5 Projects/ObstacleAssault2/UnrealLearningKit/UnrealLearningKit.uproject”"" -LiveCoding -LiveCodingModules=“C:/Program Files/Epic Games/UE_5.1/Engine/Intermediate/LiveCodingModules.txt” -LiveCodingManifest=“C:/Program Files/Epic Games/UE_5.1/Engine/Intermediate/LiveCoding.json” -WaitMutex -LiveCodingLimit=100
Quick restart disabled when re-instancing is enabled.
Running UnrealBuildTool: dotnet “…\Engine\Binaries\DotNET\UnrealBuildTool\UnrealBuildTool.dll” -Target=“UnrealLearningKitEditor Win64 Development -Project=”“C:/Users/Tom/Documents/Unreal Engine 5 Projects/ObstacleAssault2/UnrealLearningKit/UnrealLearningKit.uproject”"" -LiveCoding -LiveCodingModules=“C:/Program Files/Epic Games/UE_5.1/Engine/Intermediate/LiveCodingModules.txt” -LiveCodingManifest=“C:/Program Files/Epic Games/UE_5.1/Engine/Intermediate/LiveCoding.json” -WaitMutex -LiveCodingLimit=100
Log file: C:\Users\Tom\AppData\Local\UnrealBuildTool\Log.txt
Invalidating makefile for UnrealLearningKitEditor (source file removed)
Parsing headers for UnrealLearningKitEditor
Running Internal UnrealHeaderTool “C:\Users\Tom\Documents\Unreal Engine 5 Projects\ObstacleAssault2\UnrealLearningKit\UnrealLearningKit.uproject” “C:\Users\Tom\Documents\Unreal Engine 5 Projects\ObstacleAssault2\UnrealLearningKit\Intermediate\Build\Win64\UnrealLearningKitEditor\Development\UnrealLearningKitEditor.uhtmanifest” -WarningsAsErrors -installed
Total of 0 written
Reflection code generated for UnrealLearningKitEditor in 1.9053714 seconds
Building UnrealLearningKitEditor…
Using Visual Studio 2022 14.35.32215 toolchain (C:\Program Files\Microsoft Visual Studio\2022\Community\VC\Tools\MSVC\14.35.32215) and Windows 10.0.22000.0 SDK (C:\Program Files (x86)\Windows Kits\10).
[Upgrade] Using backward-compatible include order. The latest version of UE has changed the order of includes, which may require code changes. The current setting is:
[Upgrade] IncludeOrderVersion = EngineIncludeOrderVersion.Unreal5_0
[Upgrade] Suppress this message by setting ‘IncludeOrderVersion = EngineIncludeOrderVersion.Unreal5_1;’ in UnrealLearningKitEditor.Target.cs.
[Upgrade] Alternatively you can set this to ‘EngineIncludeOrderVersion.Latest’ to always use the latest include order. This will potentially cause compile errors when integrating new versions of the engine.
Determining max actions to execute in parallel (6 physical cores, 12 logical cores)
Executing up to 6 processes, one per physical core
Requested 1.5 GB free memory per action, 1.08 GB available: limiting max parallel actions to 1
Building 4 actions with 1 process…
ERROR: System.ComponentModel.Win32Exception (998): Unzul?ssiger Zugriff auf einen Speicherbereich.
at EpicGames.Core.ManagedProcessGroup.get_TotalProcessorTime() in D:\build++UE5\Sync\Engine\Saved\CsTools\Engine\Source\Programs\Shared\EpicGames.Core\ManagedProcess.cs:line 165
at EpicGames.Core.ManagedProcess.get_TotalProcessorTime() in D:\build++UE5\Sync\Engine\Saved\CsTools\Engine\Source\Programs\Shared\EpicGames.Core\ManagedProcess.cs:line 1207
at UnrealBuildTool.ParallelExecutor.RunAction(LinkedAction Action, ManagedProcessGroup ProcessGroup, CancellationToken CancellationToken) in D:\build++UE5\Sync\Engine\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\Executors\ParallelExecutor.cs:line 301
at UnrealBuildTool.ParallelExecutor.ExecuteAction(Task`1 AntecedentTasks, LinkedAction Action, ManagedProcessGroup ProcessGroup, SemaphoreSlim MaxProcessSemaphore, CancellationToken CancellationToken) in D:\build++UE5\Sync\Engine\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\Executors\ParallelExecutor.cs:line 268
[1/4] Compile UnrealLearningKit.init.gen.cpp cancelled
[2/4] Compile SharedPCH.Engine.ShadowErrors.InclOrderUnreal5_0.cpp cancelled
[3/4] Compile PlatformMoving.gen.cpp cancelled
[4/4] Compile PlatformMoving.cpp cancelled
Build failed.

Could someone please tell me whats wrong im going mad.

This looks like the same problem as Consistent Issue with Builds?
Is there something in common you two have?

The code also didnt work at first with the MovingPlatform telling me that it can’t find it but then the error disappeared. Now im not sure if it is still there or if it recognises it now. I’ve also tried turning off my Firewall and Antivirus, tried reinstalling the .net and verifying unreal engine but nothing worked.

Apologies that this has been overlooked,. I’ve checked the post that @Dan linked and the process was shortlisted in the last post

Uninstalled Visual Studio and .NET
Reinstalled first Visual Studio then .NET
Verified .NET was installed by typing “dotnet --version” in the command prompt
When nothing was found, adjusted PATH in System Environment Variables to have “C:\Program Files\dotnet” above “C:\Program Files (x86)\dotnet” in the list
Verified again with command prompt, this time seeing the installed .NET
Re-Built Project with Development Build Task

Its important to follow all the steps so we can rule this out as an issue.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

Privacy & Terms