Unreal doesn't load all Static Meshes correctly


Hello, Unreal does not load the Static Meshes of a few actors.Does anyone have an idea how to load all the Meshes correctly? Maybe without doing it by Hand(There are over 1000)?

Here’s how I came up with the problem:

I started the Project and loaded the “map1” for the first time. At the first time all went correctly. But then I tried to connect my project with GitHub and did what I can do best I messed it up. So I deleted the whole Project by mistake.I made a new one and connected it with Git again. But this time the map is kind of broken(see image).

What I had tried:

  1. Deleted the Content of the Project and Migrated the Assets again (like in the lesson)
  2. Deleted the whole Project and tried it again
  3. Like one but I also download the three(Linked) files new

Hope anybody can maybe give me an alternative to do it by hand. If you need more info, just ask

Is that from a brand new project with the assets migrated and nothing else done?

Yes, the Project where I migrated the Assets from were completely new. And in the other project is just the movement done.

So it’s still the original asset pack project? Did you verify that the map in that one is fine?

Yes it is the original. And I get the mistake even in the asset pack project. Even after a complete new download. So far it only worked the first time. Could it be a problem that I select all three files to extract at the same time? At least sometimes, because I did it like that even by the Project where the map loaded correctly. EDIT: I recently opened the asset pack project on UE4 version 4.25.4 instead of 4.26.2, but I had the same problem.

That shouldn’t be an issue. That’s how I do it.

Could you check the integrity of the zips by getting the SHA-256 hash? Using Powershell that is

Get-FileHash .\ShooterAssetPack.Part*.zip

The output should be

Algorithm       Hash                                                                   Path
---------       ----                                                                   ----
SHA256          F2B874EDA43A32BBF95D9F6D00DB71A4481929B1574D6DF199BB628366E8821A       E:\Downloads\ShooterAssetPack.Part1.zip
SHA256          1D700CE3A4C016801BA9D7C80A1D67A27BF1858753A7FF3EDFFD3D91BB7CD2B6       E:\Downloads\ShooterAssetPack.Part2.zip
SHA256          4EB04F7E1D20B5023D50219E300BA96ECB39445A5C6101D317194DE8722632BB       E:\Downloads\ShooterAssetPack.Part3.zip

Where \ShooterAssetPack.Part*.zip includes the path to the zips.

So I checked and the codes are exactly the same

Blockquote
Algorithm Hash
SHA256 F2B874EDA43A32BBF95D9F6D00DB71A4481929B1574D6DF199BB628366E8821A
SHA256 1D700CE3A4C016801BA9D7C80A1D67A27BF1858753A7FF3EDFFD3D91BB7CD2B6
SHA256 4EB04F7E1D20B5023D50219E300BA96ECB39445A5C6101D317194DE8722632BB

That seems fine, did you try re-extracting the zips?

Yeah, it I think I will do it again, in a few minutes. Maybe it works today, for whatever reason.

So, after re-extracting… the same result. I think I try to load the complete engine new.

Could try verifying it?

verify

Verifying of version 4.26.2 done, but nothing has changed. Now I am waiting for the download of 4.25.4.

So, I am back. The re-downloading didn’t help either. And now I am confused how that can be. Hope you have another idee.

When you retried extracting the zips did you first delete the extracted folder?

When you mean the Assetpack folder, yes I deleted the folder.

And all 3 zips are being extracted into the same folder? i.e. extracting all 3 zips using “extract here” resulting in one “ShooterAssetPack” folder?

Yes, one folder and all assets are technically there. I looked in the non extracted files and they have the same content.Those whole problem is so confusing. Nothing that normally fixes problems help. Even reloading the entire engine and folders new did nothing.

Last thing I can think of is that you might be opening the wrong project?

I right click in the asset folder on the .uproject and choose open. Could it be any help if I made a video of what i do to open the project? So you maybe spot a problem? And another question is there an option to reload all shader compilations in Unreal? Because the first time I opened the map it worked.

How you open it doesn’t matter, I was suggesting you might be opening the migrated to project (“SimpleShooter”) instead of the project to migrate from (“ShooterAssetPack”).

Could be worth trying.

That should have happened if you have deleted the project and started fresh.