Unity with Visual Studio 2015


#1

The issue with doing this is that Unity creates line endings for mac and it keeps complaining about converting them.

Heres the Fix.

Go to \Unity\Editor\Data\Resources\ScriptTemplates (It will be wherever you installed unity)
Open each cs file by right click open with and selecting visual studio.
Click File -> Advanced Settings
Change to Windows (CR LF) and click Ok
Save the file and exit.

Make sure to do this for all the cs files and you wont get any more line ending issues.


Making Virtual Studio have priority over Monodevelop?
#2

Is there any major advantage to using VS 2015 over VS Code? I use VS Code on both Mac and PC with Unity Debugging support, and I’m wondering if I’m missing some killer feature in VS.


#3

@Ben Can probably answer this better than i can :slight_smile:


#4

Thanks for this :slight_smile: