Unable to get Mesh Offsetting to work in 4.25

So I followed along with this lecture all the way to the end, and I’m getting an interesting error. Here’s the error code output.

The Result of this is that the whole car just jumps from position to position on server updates, and all that interpolation work isn’t seen at all on the mesh. Any help sorting this out would be appreciated. As I say in the topic title, I’ve been working through this course in 4.25.

1 Like

I have the same problem in 4.24.3 even if I make the replicator component public and even if I add a 1-second delay before the SetMeshRootOffset function call.

I just ended up not doing the mesh ofsetting.

Now I have the problem where the actor is smooth moving but the mesh offset is not.
The actor is not teleporting and waiting for mesh offset to catch up like it should.

So I was having this issue as well in 4.25, but I noticed that I had left in this extra line highlighted in yellow in the SimulatedProxy_OnRep_ServerStae() function. Once I removed that line I was getting the mesh offset and the constant jittering stopped.

As for the errors in the blueprint I noticed that in the editor when I would select the replicator component it would not show anything in the details, this basically is a bug.

You will have to comment out the code in the GoKart.h and .cpp file where we declare and create this component, save the files, compile, close unreal and visual studio, open them up again, then uncomment the code and save, compile again, close both visual studio and unreal, and then you can open them up to check the GoKart BP. Make sure you see the details show up. If they don’t you might have to try this multiple times. It took me about 4-5 resets to figure it out.

I hope this helps anyone, but I can’t guarantee this will fix it for you as this is what worked for me.

image

You will also need this if check in the GoKart.cpp BeginPlay. I noticed that without it the car / GoKart will jitter around.

Hey I believe I found a solution for most people having this issue with the blueprint and because of our checking to see if we have a MeshOffset it won’t fire off the rest of the code which will make the car jumpy. So blueprint isn’t finding your offset Root likely through no fault of your own.

There’s a good chance your movement replicator component(inherited) isn’t showing details its not being picked up properly by the blueprint. Try going to the Class settings like in the picture above and reparent it to just the Actor class then compile, then reparent it back to your GoKart class. Then check if your components are showing details. Hook it all up in the same way as before and it should be working as intended. Hope this helped.

3 Likes

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.