Tried many things but still not working

I tried many things but got the same error - Cannot open include file: 'd3dx9.h': No such file or directory
I know that I am missing something, but right now I do not have the knowledge to detect the main issue.

ERROR:- Cannot open include file: 'd3dx9.h': No such file or directory

I changed the VC++ directories as instructed in the video.

For confirmation, this is the path where I installed my DirectX SDK.
Screenshot 2022-09-01 185458

These paths are written in the system environment variable.

I don’t know why I am not getting the Win64 option here.
Screenshot 2022-09-01 185406

I can’t go further in the course without solving this issue. So, I’m looking for help.

Getting a new error after trying some more things for fixing the old issue:-

  1. I re-installed DirectX SDK 2010.
    After doing the first step, the old error was gone (Cannot open include file: 'd3dx9.h': No such file or directory) but after doing so, a new error started to occur.

New Error for (steamworks_sdk_149):-

  1. Till now I was working with steamworks_sdk_149, so I also installed the latest version of Steamworks SDK (steamworks_sdk_155)
    And I tried to build the steamworks_sdk_155's project file and it is building without giving any errors, but here comes a twist. When I press Start without debugging, two new system errors are popping up.

The new errors for (steamworks_sdk_155) -
Screenshot 2022-09-02 145246
Screenshot 2022-09-02 145302

  1. I downloaded and pasted the steap_api.dll file on "C:\Windows\System32" and "C:\Windows\SysWOW64" . But even so, nothing changed even a bit.

  2. I also checked the Windows 11 SKD option in the visual studio installer.

I tried everything I could but was still stuck with errors, hoping for help.

Try downloading the 1.53a version of Steamworks. This is the easiest one to build - there are issues with other versions - 1.54 doesn’t build at all. Steamworks is tricky to build and needs solid experience with C++ and DirectX to get it going - it took me a while and I’ve been working with DirectX since 2004.

Still getting this error.

I got my issue fixed by doing this:-
Disable GM option : project properties → code generation → enable minimal rebuild → No(/GM-)

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.