The visual studio code is tired

Hi all

Today I noticed strange things in the visual studio code.
Everything is as usual, I listen to Rick, I turn script on the visual studio code, I press F2(rename) and nothing happens.
Further, I notice that the visual studio code does not show errors with a red wavy line (I wrote outright nonsense).
Hints are missing when you hover your mouse over a word.
When entering an operator, there is no drop-down box that helps with autocomplete.

First, completely uninstalled the visual studio code. Including from AppData
Installed new version - same thing
Completely removed again
Installed old version - same thing

I did not change the folder with my Unity projects

Everything worked fine two weeks ago. After a two-week break, this happened

Please help, I have looked at all the information on the Internet (which is very little on my question). And I didn’t understand anything. There are very cool guys competing in the knowledge of terminology, and I’m only in the 76th lesson

Hey @snamina. Did you try installing the regular Visual Studio Community? Visual Studio 2022 Community Edition – Download Latest Free Version

I’ve seen many people having issues with VS code; maybe this one doesn’t have any problems.
You can also try JetBrains Rider for 30 days Rider: The Cross-Platform .NET IDE from JetBrains

There are no issues using Visual Studio or Rider to follow the lessons; they provide the same (or better) functionality than VS Code and are fully supported by Unity.

Thank you, but the hope of fixing the visual studio code does not leave me

I’m sorry but I never used VS Code for Unity dev work. That’s why I suggested either Visual Studio or Rider. I’ve never had any issues with them. (I’ve been using Rider for over a year without any issues)

Is there a particular reason why you want VS Code? You do understand both Visual Studio and Rider are superior IDEs compared to VS Code. The only major difference is the install size (if you are limited on hard disk space). Taking that into account and the issues I’ve seen posted here, why not try a superior product?

You can read more about the differences & Benefits. here https://forum.unity.com/threads/benefits-of-visualstudio-over-visualstudio-code.1181764/

1 Like

Hi snamina,

Please follow the instruction on this website and make sure all required extensions are installed: https://code.visualstudio.com/docs/other/unity

If the issue persists, please check the console of VS Code (not Unity!). If the .NET Framework 4.7.1 (Developer Pack) is mentioned there, download and install it from the official Microsoft website. Here is the link: https://dotnet.microsoft.com/download/dotnet-framework/net471

Depending on your version of Unity, it might be that you will have to install the “Visual Studio Code Editor” package in Window > Package Manager in Unity.

  1. Press Ctrl + Shift + P in VS Code.
  2. Type “OmniSharp: Select Project” and press Return.
  3. Select the solution workspace entry.

Maybe you’ll have to reboot your computer. Then launch Unity again and open one of your scripts.


See also:

1 Like

Yes, you are right, I will probably use the Visual Studio

Thank you guys for your help, problem solved. I don’t know what exactly helped, but my last action was to install .NET 6.0 SDK (v6.0.301) and roll back the Visual Studio Code to version 1.2.3. After these steps, the problem was not resolved. I turned off the computer, today I turn it on and everything works. Magic!

I’m glad restarting the computer helped. :slight_smile:

I restarted my computer about 10 times after uninstalling and installing VSС. The computer probably needed a good sleep :slight_smile:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.