The compiler does not compile. I use Raylab 4.5

I started to follow the course until I got to this lesson. Despite having followed the steps and then seen the fixes to apply, the compiler does not go.

i follow also this “How to fix - “C:\raylib\w64devkit\bin\mingw32-make.exe” does not exist” but nothing to do.

How should I solve it?

p.s. I solved it. i downloaded the template from here (

I deleted the ‘main.cpp’, created the ‘hello.cpp’ and debugged it, the compiler worked correctly. I can now use this template for other projects.

I had the same issue. If you get this code from the Github site it works. You have to delete the make.cpp but other than that everything is good.

1 Like

Also, did you choose a custom path to raylib installation or did you move the raylib folder to another location? The build task assumes you have raylib installed in C:\raylib\etc.

While you’re certainly allowed to use a different template if you wish, please be advised that if you run into an issue with it then we might not be able to help you.

That said, it looks like you’re using an older version of our project template. Which worked with versions of Raylib before version 4.0, we have updated our template since to work with the current version of Raylib.

That said, if you grab any of the lecture commits then you will need to update the .vscode folder and makefile using the project template via copy and paste. Those cannot be updated by us

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms