Steam OSS server search

Hi everyone,
I am facing an issue while searching for servers as a client when two players are already present in a created server. This is only happening when I am searching for servers over Steam. It’s working fine when created and searched on LAN.
Been following the Unreal Multiplayer course and it’s been helpful so far. But, I can’t figure out the solution to my problem. I tried naming my session name to NAME_GameSession as suggested in the tutorial. It fixed things for LAN but not for online Steam OSS.
Steps to recreate:

  1. Create a server.
  2. Join the server as a client. So, two players were already present in the session.
  3. Try searching the server from a third machine. Not getting any search results so not able to join. As soon as one disconnect, then the other one is able to search.

Checked max players and everything in Server Settings.

Are you using 3 different computers with 3 different steam accounts?

Yes @beegeedee

I don’t have access to 3 PCs to test this but it should just work - I used sandbox to test with a different account.

There’s not that much of a difference between the steam and null OSS in terms of implementation, a few settings and that’s it.

A small check list to confirm here.
your code matches what’s in the course repo.
Are you using builds and if so, are they all identical?
OR are you using the editor for one or all machines?
Any firewall issues from any of the machines.?
Have you tried a server from a different one of the 3 machines and connecting from a different one first each time?

I would suggest a build for all 3 rather than the editor. This would ensure they are all using identical code/builds for testing.

Let me know how you get on.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.