Sourcetree CredentialHelperSelector keeps popping up

Hello, I’m following the Git course and am currently on the Push and Wrap-up video. I tried to push but this popup window showed up


I just selected “manager” and moved on but the window popped up again. Any idea why this pops up? Is there a better credential helper to choose?

been trying to read up on it on the Atlassian site. uless theres something funny going on with the windows credential manager in the control panel. im not that well up on VC or sourcetree, only use the very basics.

hope someone can offer some help to get round it.

1 Like

I’m not sure what solved this to be honest but I haven’t had this issue in about a week. In case anyone sees this I’ll outline what I did below

  1. Attempted this thread’s solutions to a separate credential manager related issue
  2. Uninstalled sourcetree
  3. Renamed folder AppData\Local\Atlassian\SourceTree to something else, anything should work
  4. Reinstalled and followed git course up to needing to select a manager
  5. Selected wincred, might need to select one more time in case of another pop up
1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms