[SOLVED] Project finished...don't know why this strange message is coming up!

Hi guys! I’ve just finished NumberWizard but i have a problem. Everytime i try to play the test the game this message comes up in the console
"The referenced script on this Behaviour is missing!".
I’ve tryed anything…even delete the script, make a new one coping the content that from the Lecture resource of video 21 but nothing’s changed…i’m at video 22 (10/13 of the NumberWizard Section), i can skip it, i have already finish the game but i HAVE to solve this problem…it’s like when you’re downloading something and it stucks at 99%! So please HELP me, i HAVE to finish this game correctly!

Thank you very very much!


Moving or renaming a script can cause that. Might see if you can “add it back” in the inspector panel.

Hey man! tnx for the answer! i haven’t moved anything…the only thing i’ve done is installing the Unity Test app for iOS and make a test on my mobile device. i even try to make a new project from zero and make new scene, new C# Script etc etc…i tried even on Unity 5.4.xx…
i don’t think that having 2 Unity versions (installed in different directories of course) is a problem…before this message everything went fine…

i can’t understand what’s happened…

Problem Solved thanks to the Discord group and Irresistible Jelly!

Privacy & Terms