rotationThisFrame name is confusing

I just wanted to mention that I think naming the variable rotationThisFrame in the method declaration is misleading. The variable we’re passing into it is still the full rotation thrust, and it only becomes the rotation this frame once multiplied by Time.deltaTime. The name doesn’t affect how it works of course, it would function exactly as Rick intended even if we had called it squashedBanana, but I just thought it was worth mentioning in case anyone was trying to figure out why we were naming it that.

Since it’s in the Update() method, it is getting called and refreshed every frame, so it’s technically correct, but I still called it “rotationFactor” instead, as I felt that was a clearer interpretation of what the variable is doing.

Privacy & Terms