Rotating causes animation to go crazy

I am trying to create an animation but I cannot rotate the object. It gets to a moment where I need the camera to rotate otherwise Im not able to see the rest of the scene. what happens is, I am always moving on X,Y,Z in line but If the movement causes object to rotate around it self all the previous recorded steps will go crazy. By go crazy I mean, the camera moves to another place that is not the ones I recorded.

I tried many different ways. I try to rotate manually the object. I tried to use Align with view. I tried to Move to view. I tried to stop recording rotate and then start the record again. Any ideas what else I can try?

Also , by trying, I notice that if I record a rotation by itself, not moving under x,y or z it will work fine. If I do both at same record, it will go insane

Actually, it was lucky, still doing same thing


Make sure that the very first keyframe contains all properties that get accessed in your animation. If you don’t do that and access a property for the first time, for example, in keyframe 20, the animation will use those values for keyframe 1 anyway, and you might get undesired effects.

Of course, the properties in keyframe 1 should have their initial values.

I hope this helped. :slight_smile:

See also:

Hello Nina, sorry for late response.

I tried that, and I have been trying other things.

I even recorded a screen of what is happening: - YouTube

I also tried to put the rotation of playerRig on the first frame on (0,0,0) same issue

You are recording with an initial rotation offset. This may result in a misrepresentation of euler angles. When recording transform properties, it is recommended to reset rotation prior to recording. How am I supposed to do it ?

Unfortunately, the video is not available, so I cannot watch it.

Regarding the problem with the angles, please share a screenshot of the animation where I can see the first keyframe selected and the expanded properties with the values of the first keyframe.

here it is

That looks fine. I would suggest to click each waypoint and adjust the rotation values manually. Unity internally works with Quaternions. We use Euler angles, and the Euler angles get converted. The conversion might be mathematically correct but the result could still be “wrong”. It might be that you see -360 instead of 360 in one of the waypoints. Both values represent the same rotation but do different things.

Privacy & Terms