Realm-Rash exercise

During my Realm-rush practices, I encountered a problem which is my enemy goes inside the cubes when It starts pathfinding and moving towards the end, at first I wrote the code on my own but I had some other problems then I wrote the one that was shown in the video and this happened.
may anyone walk me through this, please


Have you already rewatched the video at least one more time?

If the only problem in your solution is/was that the enemy goes inside the cubes, add Debug.Logs to your code to see what’s going on during runtime. It might be that the faces (children) of the cubes just need to be moved down a bit.

The position of a child is relative to its parent.

I’ll try, I’ll reply if the the problem is not solved

Sure. And if the problem is solved, it would be great if you could mark a solution. :slight_smile:

See also:

actually not only had I wrote the pathfinder.cs script on my own ( however I did undo It ), I had also changed the waypoint.cs and cubeditor.cs and I forgot about them then I changed them back to their original form and Debug logs aided me as well

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms