Radial Force does not work STILL

Hey @ben I read into the other thread about this but the radial force bug was NEVER fixed it seems I tried the solutions you proposed to the other guy but it just does not work for me when i try the ExplosionForce->FireImpulse();

Please help haha I have short time frame to work with on this course so I will just end up dropping this feature of the game and moving on if I dont get a response back soon sadly :frowning:

Hi there, you are safe to drop this feature and move on.

If you really want to get it revolved, our student instructor @DanM can likely help.

If you’re still struggling do get back to me.

What bug?

ExplosionForce->FireImpulse(); was not firing off even though the hit was detected. I have dropped this feature and I moved on. Already in the next section. Feel free to answer it in case anyone else runs into this problem.

he’s talking about the radial force issue we never solved.

I stopped replying cuz I was wrapped up in the modeling course. I didn’t know I could just mention you or that you were active in the Q&A when I originally posted all these problems.

I solved that. You weren’t simulating physics on your tank so the impulse wasn’t effecting your tanks.

1 Like

How is that possible? In what context do you mean this; as the tanks have to be simulating physics to move?

Ugh I was gonna look at this to see what you meant lol hmm. I’d have to set everything up on this new PC though as my room doesn’t even have power; lols…

wow. So that was it? All that headache?

So… hmm. I will have to confirm this later because I dont even have the project on hand.

I’m trying to comprehend how these objects even interact like that… If the children are simulating physics you would think they would drop to the ground without the parent, but somehow the children would be controlling the parent’s location otherwise…

@Pearson_Programming does that fix it for you?

You would think you’d still get some sort of visual representation. Though the last time I tested this i did get a rare hit result. Not to mention the tank tracks should be easier to hit then that. I’ll try to test this later.

@Pearson_Programming on your Tank body, change your collision preset from WorldDynamic to PhysicsActor.

1 Like

This fixed it @Steve1222

Edit: it only works if it hits a sweet spot on the tank @DanM

The collision mesh is interferring with the inpulse, rearrange it so it’s destroyed before you fire the impulse

//Do this first

I’m testing it myself now. At first it would appear to be working, but then yeah, it might seem there is the sweet spot problem, as when i’m getting hit by enemy tanks I only take damage sometimes. But this might be a problem with the radial force damage which also was having problems.

Ok so yeah, The firing of the radial force component was solved by ensuring my tank body was simulating physics.

But i do have occurrences where I do not take damage.

Its funny because I tried changing the order of those commands dan mentioned a bunch of times, to no avail.
But for whatever reason, I tried changing the order of them to the order he suggested, and as of now it APPEARS to be in working order.

Faulty code order:

^The order I had my code previously (not working properly)

Working code order (as suggested by Dan):

^changed a couple code orders around and this time it looks like it working

To be honest, its hard to tell 100% surely that its working without flaw, but so far I dont THINK i’ve had any improper occurrences where I don’t take damage. (its also been a while since I’ve worked on the unreal course so my memory is foggy on this, but thats enough non-3D-modeling brain taxing on this stuff for today)

@Pearson_Programming let me know if you have any draw damage or sweet spot issues after changing the call order.

1 Like

It might also have been because I uncommented those two lines of code I had commented out. hard to tell.

In fact, I think that was it. I also think I am taking less damage now? It mite have been taking extra damage before…

Privacy & Terms