Problems with the Inspector


I have a small issue regarding the inspector. For some reason when i try to open (in the inspector) the Tank Player Script, so that i can give it the references to the Wallet script i get a cast error. I have never seen something like that. Maybe someone can help.

Here is my Code in the script

Should be the same as Nathan descriped it.

Maybe someones knows whats going on here. Ty for the help

Well this is a strange bug, what version of Unity are you using?

I am using Version 2022.3.10f1. I fixed it for the moment by hiding the fixedString in the inspector. I guess it cannot render it in the inspector.

1 Like

This bug must be specific to your version of Unity or Netcode for GameObjects (what version of the latter are you using?).

I’m glad you found a solution for now.

i am using Version 1.6.0 for the package “Netcode for GameObjects”

Same problem here. [HideInInspector] also fixed it for me. I thought I was losing my mind. Thankyou!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms