Problems with the game view

Hi there,

I am having some trouble in the game view (3 troubles). I believe these have relatively easy solutions but I could not find one.

As you can see in the screenshot, my game object’s components are highlighted with green when the game object is selected. I would like to adjust the parameters in the game mode but it is hard to see the movements in this view. How can I just see the spaceship without any components highlighted?

Moreover, the track of the circuit (yellow) somehow does not disappear in game mode. How can I make it disappear?

Last but not least, the game slows down considerably during some interval. I think it is about the resolution/graphics and my laptop’s hardware but it did not get much better after I adjusted the graphics.

Many thanks in advance.

Best,
Can

Hi Can,

Thank you for your questions.

Try to click on the Gizmos button once to disable all Gizmos. If that worked, enable the Gizmos again and click on the arrow next to the button. Make the colliders invisible in the menu.

Check the Gizmos menu. I think there is also a Gizmos button in the game window. If you don’t want to see any Gizmos in the game window, disable the Gizmos completely.

The game window is nothing but a preview, and it is usually a bit laggy. For this reason, if you assume there might be an issue in your game, build your game and play the built game. If you use a laptop, plug the power chord in because, otherwise, it might be that it is running in energy saver mode.

Did this help?


See also:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.