Problem with Custom Network Manager

Hi Everyone! I’m trying to create the custom Network Manager script in the multiplayer course. I’ve followed all of the discussed steps and made sure to erase MonoBehaviour from the new script and added NetworkManager. When I drag it into the NetworkManager game object, none of the fields show up in the inspector that should have been inherited from NetworkManager. My RTSNetworkManager script has no code aside from the removal or the MonoBehaviour part and adding “using Mirror;”.

I’m attaching a picture to help show the problem in the inspector. Any ideas? Thanks!Network Manager Problem

Ok, I solved the problem, but I have no idea what happened. I created a new script to try and replicate the problem. As soon as I created another script in the same folder as RTSNetworkManager.cs, it seemed like the RTS script snapped into shape and decided to start inheriting from NetworkManager.

So now it works as intended. I’m not sure why this worked, but maybe someone else will have this issue too. :man_shrugging:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.