No collision detection between Goober and platform

Hi, for some reason I’m not getting the collisions triggered.
I am sure [edit] (I was sure) I followed the video and doublechecked the code. Just to make sure I also removed CapsuleCollider.

After I spent more than 30 minutes searching the internet I found “Use Full Kinematic Contacts” checkbox to fix the issue. But I do not understand why is wasn’t working before and why is it working with that.

My unity version is: 2022.3.7f1

Could you please explain?
Thank you

Ho oglop,

Good job on solving the problem. :slight_smile:

Unfortunately, without knowing anything about the other colliders in your scene, it is impossible for me to do some research on the problem. Were the other colliders set to static?

See the description in the API:

When this property is disabled, the Kinematic Rigidbody 2D only collides with Dynamic Rigidbody 2Ds.

Hi Nina,
Thanks for the note about colliders!
I must have been tired or missed it… I went back to the video 3 more times
then I found out it has mentioned “Trigger” not the collision!
My problem was that I used OnCollisionExit2D(Collision2D other) instead OnTriggerExit2D(Collider2D other) … with the correct method I could uncheck the checkbox, but I learned something interesting.

Not just interesting but something important about Unity’s physics simulation. It will be helpful in future projects. :slight_smile:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms