Network Manager

Facing 2 types of problems

  1. Strange Issues like :
    when I write like this ( following the tutor)
using Mirror;
using System.Collections;
using System.Collections.Generic;
using UnityEngine;

public class NamaxNetworkManager : NetworkManager {
       public override void OnClientConnect(NetworkConnection connection)  

        Debug.Log("I connected to a server!");

Error shows :
*** error CS0115: ‘NamaxNetworkManager.OnClientConnect(NetworkConnection)’: no suitable method found to override ***
& due to this I cant run to check the scripts.

but when I right like this :

 public override void OnClientConnect()

     Debug.Log("I connected to a server!");


it shows me only warning with successful Run :

** No Transport assigned to Network Manager - Using KCP [7777] found on same object.
UnityEngine.Debug:LogWarning (object) **

  1. related to un-matching Assets
    when I changed MonoBehaviour to NetworkManager

I had to to add 2 scripts manually instead of 1 ( like tutor did : he added only one scripts from the Mirror assets naming Network Manager HUD for interactable buttons/UI )
one was of KCP Transport (script) / Telepathy Transport(mirror) (tried to switch one-by-one check if my error goes off or not but didn’t worked)

Hi there,
A lot has changed in Mirror since this course was released. If you are using the latest version of Mirror or a later version of Unity you should expect to seem some differences.
Your first example is an example of where they have changed the parameters for a method, so it doesn’t recognize the method signature. In those cases, just jump over to the script and find the method there and check out what the new parameters are.
You should also expect to see some variable name changes, and some different editor work flows as you indicated.
Hope this was helpful! Let me know if you need any help navigating the differences.

1 Like

well it helped but still I am facing a Log Warnning

That warning might just indicate that you need to drag the Transport component into the transport field on the Network Manager, though it seems to have found it by itself since it is initializing normally.

Figured it out , It got solved when I Dragged **Telepathy Transport ** Script

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms