NavMesh is built in editor, but ai doesn't use it

I followed the cpp tutorial and built a navmesh, AIcontroller, blackboard, behaviortrees and all that, but the ai doesn’t move. After digging around, I found out that the navmesh is not showing up in the navmesh debug in game. I tried to ask on unreal forums with screenshots included: Nav mesh is built, but not being used in-game - AI - Unreal Engine Forums
but got no answers. What should I do?

Could you show your nav mesh?

here’s the navmesh in the editor:

here’s the navmesh and ai debugging showing in game when pressing the ’ key

here’s the navmesh in a new project to test if my code was wrong

here’s the new project running

this part is where it keeps getting stuck. if fact, the MoveTo seems to be stuck on that particular project. I’ve tried to use Moveto only in cpp and blueprint but nothing helped.

Not quite sure what’s going on there. The visual logger might give you a good insight as to what’s going on, Tools > Debug > Visual Logger

Visual Logger | Unreal Engine Documentation

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

Privacy & Terms