My First Level, but how do I fix lighting?

Here is my first level for Project Boost… but it is so dark!
I can’t seem to get the ambient light higher to reduce the contrast.
Its so hard to see the walls. How do I lighten the scene?

Hi there!

You can always add different types of light and play around with them, or just adjust the “Sun”, the Directional Light already placed in the scene.

@Michael_Marinis_GR is correct! Also, one thing that isn’t so clear when you’re first starting out is to adjust the rotation of the directional light. Position has no effect but your objects could simply be on the shady side of the world’s light source.

1 Like

Experial has the right solution with adjusting the rotation, that will definitely help your issue!

If it feels a little too much trying to play around with lights right now, I am pretty sure Rick ends up diving into it a little more with you in a lecture pretty soon. He uses lights to help design the challenges and to help with the user experience, so don’t worry too much about it now if figuring out the light seems a little clunky.


I just want to add that if the lighting does not change when you move the lights, go to Window > Rendering > Lighting Settings, scroll to the bottom of the Inspector and click on the “Generate Lighting” button. It might be that auto-generate lighting is disabled. There is an option on the left-handed side of the button. If you have a fast computer, you could try to enable it but the editor might become slow because Unity would recalculate the lighting whenever you change something in your scene.

Is the issue fixed?

See also:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms