Marble Run. Ball acting weird

I’m Using 5.1.1.
I’ve done all the settings in blueprints. Teleported the physics.
The ball just sinks into the floor. If I turn off teleport, then the ball reacts to the floor again, but it goes flying into the air.

I have the same problem

I found that if the ball drops to the surface before I click “into” the game, then the ball become unresponsive and sinks into the gameboard when moved. However, if I click into the game before the ball touches the gameboard, then it appears to work as it should.
But I have to drop the ball onto the gameboard, from a height, and click into it before it lands.

Any ideas on why this is happening, and solutions to the problem?

Physics in UE5 is more eager to put objects to sleep when at rest, causing them to not longer interact with non-physics objects.

You can learn more about it and a provided solution at Using this course in Unreal Engine 5 doesn't work

A note on this has also been added to the course recently.

Yup, I followed that solutions. They sort of work.
I found you have to drop the ball, and “click into” the game before it hits the gameboard. Not sure why, but it lets me use it to follow the tutorial… so far
Not sure how it would work, if you were to export it as a game though. Not that that applies here. Just a thought.

Also, if the ball stops moving for too long, then it goes static again.

Did you make sure to enable “generate wake event” for the ball? It’s the key to making the solution work (and something that accidentally got left out in the note for the course. I’m pushing an update through)

Yes I did. (See pictured)

I might try dowloading 5.0 see if it’s a 5.1 problem.
I don’t really want to go back to 4.27, I want to learn the new system.

What you learn with this course in 4.27 would translate well into 5.0 or 5.1. And the Marble Run section is the only one with a problem like this.

Thank you, I’ll just watch through the rest of the marble run, and continue on afterwards.
Thanks for your help.

There’s a fix needed as the physics goes to sleep. There was a post here about it. It is a matter of reactivating the physics. It was an issue identified in 5.0 previews and is still present in 5.1

EDIT: Try this: Using this course in Unreal Engine 5 doesn’t work - Unreal Courses / Ask -

I had also to use “Event Tick” because by using only “On Component Sleep” was not working for me

Ok. Will give this a try!

You want to make sure “Generate Wake Events” is on, which you can find or search for in the details panel.

Did that, it still acted up in the editor.
Regardless of any issues it has in the editor. The ball moved great in the packaged “game”.

Just never got the trigger box to work. It’s worked before in other tutorials. Not sure what the difference is in this game.

Anyway, onwards and upwards to the next level.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

Privacy & Terms