Ladder animation not triggering fast enough

When my avatar begins to climb the ladder, he doesn’t swap to the climbing animation until after a few seconds.

What did you try so far? It’s probably due to it only being able to transition in a certain state, so the animator controller has to finish the state it’s on, then return to the state that can take it to the climbing animation.

How do I fix that?

Hi,

Click on the transition arrow between the current state and your climbing in your animator window. Make sure the Exit Time and the Transition Duration(s) are set to 0.

Thank you, I fixed it!

Good job. :slight_smile:


See also:

Wait nevermind, I’m really sorry. I realized I was talking about a different bug when I said I fixed it.

I’ve checked the transitions; they are all at 0. :

Here is a video of the bug

https://drive.google.com/file/d/17noX4JgF4_65eaGKtx2SPj6mX3MyaVf9/view

Thank you for the video. I’m afraid I still don’t know what the problem is. The movement of the player looks fine to me.

Is one of the player’s colliders still touching the ground when you expect the climbing animation to be triggered?

image.png

It’s not really a big deal, but just a quick question I have the auto paint function set up, but when I try to pain it just paints whatever block I have selected. How do I use the auto paint?

What is auto paint? Or do are you referring to the tile rules which make Unity replace certain tiles if their neighbour is a specific tile?

I found a way around by painting everything manually. Here is a video of the game. (So far) chrome-extension://mmeijimgabbpbgpdklnllpncmdofkcpn/ng/app/app.html#/files/2ec7d4d7-4349-41fb-ye5b-3e11daeff174

https://drive.google.com/file/d/1cv174UU6IjrKdKgfbcttlX4eGnr6jiHb/view

Good job. :slight_smile:


See also: