Is it necessary to have two different variables for the same use?
First, why can’t you call the starting wave the current wave because that’s what is current.
For example, this is the code:
int startingWave = 0; void Start() { WaveConfig currentWave = waveConfigs[startingWave]; StartCoroutine(SpawnAllEnemiesInWave(currentWave)); }
Why not have it this way:
int currentWave = 0; void Start() { StartCoroutine(SpawnAllEnemiesInWave(waveConfigs[currentWave])); }
or even this way:
int startingWave = 0; void Start() { StartCoroutine(SpawnAllEnemiesInWave(waveConfigs[startingWave])); }
The point being is to have one WebConfig and one line in Start(). I am confused as to why.