Include "OnlineSubsystem.h" build errors

Everything works well until i add “onlinesubsystem.h” to game instance. Then i get these errors:


What might be wrong? Only thing i did not as like in tutorial is steam api folder location (i copied it to project and upper project folder)…

Did you setup the include paths correctly in your project?

Well, this is pretty strange. I think everything was set up correctly because i was able to open document OnlineSubsystem.h …
After i downloaded your project, your project worked fine on first try and then magic happened, my project was able to compile…
I did not changed anything and it worked after like 10x restarting VS and UE… probably some C++ism.

Hmm, strange. It might be some cached build products in VS.

Hello,

I too had this problem where I was not able to include “OnlineSubsystem.h”. After including all the steam SDK information in my games properties, I got the error "cannot open source file “OnlineSubSystem.h”. The solution I used was simply to generate the visual studio project files and reload the sln file. This fixed my problem, I hope it solves yours.

2 Likes

Not sure if includes are case sensitive…but think it is “OnlineSubsystem.h” with only one capital S.

They are.

Thanks Doministic, You have saved me from big stress.