#Include errors, update include path. (Section 2 - Bull Cow game)

Hello everyone.
I’m slowly making my way through the Unreal Developer course. I have reached Section 2, Lecture 43 via Udemy and i’m getting an include error and am asked to update my include path for the BullCow Cartridge.cpp/.h files.

I’ve tried digging both on here on discord and via the community forum (Bull and cows #include path error I couldn’t find the answer via Lecture 43, I assume the course has been updated so this answer may be outdated.)

I also found this: IncludePath again I can’t find the lecture with the solution mentioned on Udemy (I have tried refreshing the project via Unreal as well)

But i’m unsure what I need to do to update the include paths or the solution if someone can help?

The lecture video in question I cannot find about this bug in Unreal 4.25, and a topic that was on here/Udemy either leads to a non existent page or just creates a new tab on the same video currently watching rather then leading me to the lecture in question.

I’m using Windows 10 Pro, Unreal 4.25.4, VS Code 1.55.2

I tried following a video I find from this person’s topic: VSCode issue - headers not recognised

Following this video: https://www.youtube.com/watch?v=yAUgFZh28aA

To add the code for the defines within c_cpp_properties.json found here: https://cdn.fs.teachablecdn.com/5GuRLyP1QtGXtVRTS6Cp

This does stop the error with the header files, but now I have a new error where I believe it doesn’t recognize the class/namespaces, and it expecting a semicolon in header file.

Because this is provided, I’m unsure what to do here… I’m not sure if what I did above resolved this initially or just caused more issues.

Hello Gaeas_Freikugel.

What is the error you have on your .h file?

Hello Valentin_Bonneau,

See the image below:

It’s expecting a semicolon but i’ve not written these, and from what i’m seeing it’s referring to a class here I believe? This is just the bull/cow game extracted from the resources.

This occurred when fixing the include path errors.

Have you followed meticulously what the videos instructed?
It worked well for me…
Have you changed the project name at the end of the “defines”?

1 Like

I wasn’t able to replicate in the video where it shows to modify the path at 2:54. The lightbulb isn’t available in the Bull Cow game includes.

For the one created as shown in the video the lightbulb says to edit, not add include path. So this part of the video I wasn’t able to follow this part.

On reviewing the video I realised the ‘VTABLE’ and ‘_API’ the project name is supposed to be in uppercase, I wrote it like I did for the ‘UE_PROJECT_NAME=’ segment of the define.

So for future reference hopefully this will help others.

                "UE_PROJECT_NAME=ProjectName", // Change to how the directory/folder is written
                "PROJECTNAME_VTABLE=DLLEXPORT_VTABLE", //uppercase
                "PROJECTNAME_API=" //uppercase

Thank you for taking the time to help Valentin_Bonneau, this was driving me crazy. Is this something I need to keep in mind for all the projects due to the issue with 4.25?

Glad to hear you managed to solve your problem :slight_smile:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms