I have no idea what to do anymore

I keep getting build errors no matter what I do. I have uninstalled and reinstalled Visual Studio and VS Code a handful of times already, as well as removing all associated tools and reinstalling everything. This particular issue seems to be with .Net.

I followed the directions and installed .net 6.0 and I still get an error telling me to install a version newer than 4.6. I also installed 8.0 and nothing worked still. I have removed and re-added paths, countless reinstalls and pasting my error message in Google so far has not led me to a fix that worked.

I have tried modifying and adding individual components through Visual Studio (I am using 2022 Community), tried compiling both in Unreal and VS Code and tried refreshing code in Tools bar in Unreal. Everything was working fine until yesterday but it’s all blown up and I am seriously at a loss. I have attempted to leave a screenshot of my error message so hopefully that at least works. I’m so bummed. If anyone can help me get out of hell I would appreciate it so much

Ah, OK.

This is a very confusing error.

There are 2 versions of Dot Net. The first is the original dot net framework which is windows specific and goes to version 4.8.the second is dot net core and this currently goes to v8, possibly with v9 due soon. Unreal needs core v6 and the original dotnet to be installed as well. So you have core 6 installed, you probably wondered why it is asking for 4.6 or later well…

Well, that is why. It isn’t the same library. Try this link.

1 Like

Yeah this is following Microsoft’s MO of terrible naming of products.

There’s the original “.NET Framework” that is Windows only. Several years ago they created an open source and cross platform version called “.NET Core” which went up to version 3. That was then rebranded to simply “.NET” with a version number of 5.


Thank you so much! This worked and got me past that problem. I would have NEVER figured that out.

However, now I have a new problem, apparently. I am using the Obstacle Assault project to test compiling because I had completed the lesson and there were no issues or errors.

Now I am getting this error that is saying the project files have been modified or are new; and I have not modified them or made new versions that I know of. They are in the same folder they have been and I made no changes to either the project in Unreal, the cpp, or the header file

It also says something about the order of includes changing and I’m not sure if it thinks my engine version changed or what, but I have been using 5.1.1 since I started and haven’t changed versions at any point

I really feel like I’ve broken the whole thing lol

I truly appreciate the help

Check this post out as it may be related to this.
Compiling issue. UE5.3 - Unreal Courses / Ask - GameDev.tv

1 Like

I was just coming back to say that after a development build in VS Code everything compiled without errors and seems to be working fine for that project. I should have thought to do that before posting, but thank you so much again.

Still having some issues with Crypt Raider section but I will work on trying to troubleshoot these myself for a bit before bothering you guys again lol. I seem to at least be back to where I was before it all blew up.

Your help means a lot. I was really enjoying the journey and I’m hoping I can get back to making progress soon. You guys rock!

Happy Easter if any of you observe

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms