I can't get the constraints to work

24_al_cbc
complete-blender
#1

As the title suggests, I can’t get the constraints to work properly, after reaching the maximum limit angle the bone shifts back at the original place. Here’s a screenshot.


According to the video, it shouldn’t pop immediately back in the original pose, but rather stop rotating.
After some testing I see that the problem starts when the maximum angle hits 180 degrees, after that it goes back in the minimum angle.

#2

I’m not sure if it’s the solution but remember to change the “World Space” to “Local Space” in the bone constraint then the snapping won’t be so horrible

1 Like
#3

I did that and while it does let me move past the 180 degrees limit it still snaps back at the minimum angle the second I move past my maximum. From the videos I would have expected it to stay at the maximum angle until I reached the minimum by rotating the rest of the cycle, for example it should stay at 210 while I rotate past 210 and until I reach -30.

#4

Ah i have found this topic following this one now :slight_smile:
Has this now been solved wiht the constraints video as suggested in the other thread?

#5

Let me copy what I posted in the other thread to this one as well.

#6

The random snapping on Mike’s lamp was resolved, since he didn’t upload it with local space and that was causing the lamp to snap at random points during rotation, just like it did in the lecture. My problem still remains, and it is that after I rotate past 180 degrees on the local axis of the bone, instead of it continuing the rotation and remaining stationary after maximum like it does in the video, it instead snaps back at the minimum angle. For example, if I set the minimum angle at -10 and maximum at 210, when I rotate past 180 it should keep going and stop at 210, but instead it snaps back at -10.

#7

Lamp Scene 3.blend (770.2 KB)

#8

Here is the file after switching to local space.

#9

Thank-you,

Okay so i think i have found where the issue has occured apart from the naming that needs to be sorted out :slight_smile:

  1. The constraints on the bone constraint for the lower arm bone are incorrect. its -80 and 130 not -80 and 210

  2. That same bone has a deform on it that Mikey had forgotten to turn off which he does so on the upper arm bone and then realizes and doubles back.

I suggest rewatching from around 8 minutes :slight_smile:

Once you have these done and you double check these constraints you should be all set.

Let me know if you have any issues.

#10

Are you talking about Mike’s lamp or mine?

#11

On yours this is.

So your lower arm bone constraints are incorrect and the lower arm bone also still has deform ticked on it.

There is possibly other things to check but got a wife nagging me to go dig the garden again atm :confused:
Got to love half term holidays.

I will try to reply when i can

1 Like
#12

Ok, how are they incorrect? I ticked off the deform option but it still does the same thing. The upper bone didn’t have deform ticked but it behaved the same way.

#13

The lower arm bone contraint on your model the max on yours is 210 for some reason.
Mikeys is set to 130.

What we are doing is setting you back to the values in the video so we can trace the issue.
I dont think the model is rotated and i am pretty sure when i looked all your bones matched the same rotation as Mikeys in the video as well.

Its worth checking it over as well to make sure all is well in it.

#14

Ok, I tried setting the constraints on Mike’s model and they work just fine.

#15

Even with deform selected.

#16

Okay i’ve had a closer look and whats happened is and i am not sure how but all of your bones are different armatures as well.
You need to unparent all of the mesh items in the scene, Delete the armatures and add a new one and extrude from the original head of the stem bone, Then reparent all of the mesh items to that armature.

I’m not sure how this has happened but if you look under each bone named you can see they are armatures of different numbers so this is why it is not working.

I’ll check in with you tomorrow on this one :slight_smile:

#17

Ah, so they need to be in the same armature to behave normally?

1 Like
#18

I tried remaking the armature, but it does the same thing.

#19

I’ve been working through the Character Creator course in 2.80 and ran into this same issue with the constraints snapping around when rotating past the constraints limits.

I’m including a link to the file, maybe looking at it will help you find a solution. I ended up moving on without finding a solution and the following lessons rendered finding one pointless.

#20

So you’re telling me I spent 2 days trying to figure out why this is happening and it doesn’t even matter xD?
Dat smile on the skelly.
Yes, after looking at the model it has the same issue, as soon as the angle passes 180 degrees on the local axis it snaps back at minimum angle. But apparently that only happens if you set the maximum angle over 180 degrees. I tested the skeleton with a max of 120 and it behaves normally.

1 Like