How I got this working

Step 1:
Open the sdk\steamworksexample\SteamworksExample.sln file from a fresh unzip, press ok on the upgrade progress steps:

Step 2:
Open up the solution explorer and then open up the SteamworksExample, right click on References > Manage NuGet Packages…
image

Step 3:
Go to the Browse tab and search for " Microsoft.XAudio2.Redist" = NuGet Gallery | Microsoft.XAudio2.Redist 1.2.6, select it and click the Install button (accept license etc…):

Step 4:

Repeat step 3 but search for “Microsoft.DXSDK.D3DX” instead: NuGet Gallery | Microsoft.DXSDK.D3DX 9.29.952.8

Step 5:

Build solution with F6 key.

you may get C1001 Compiler error:
Double click the error and it should open the file steam_api_common.h of line number 156 put a comment in front of it

Build again with F6 key, I get an error about the d3dx9.lib to fix this we find the path of this file:
Go to the location of your SteamworksExample.sln and a folder “packages” should be created, dig down to “Microsoft.DXSDK.D3DX.9.29.952.8\build\native\release\lib\x86” now copy this whole path including the drive letter and add to the properties pages VC++ Directories:

After this do a build (F6) and then a Local Windows Debugger (F5) to start the game.

3 Likes

Thank you for this :slight_smile:

Great work. Now I’m stuck at fatal error LNK1104: cannot open file ‘kernel32.lib’. Any insight into this fix? People mentioned it might be something with the WindowsSDKKit.

I found the problem. When following the Direct X SDK tutorial i removed the original include files that came with the project. Now my includes look like the following:

Include Directories: $(DXSDK_DIR)Include;$(WindowsSDK_IncludePath);$(VC_IncludePath);

Library Directories: C:\Users\PC\Desktop\SDK 1.5\sdk\steamworksexample\packages\Microsoft.DXSDK.D3DX.9.29.952.8\build\native\release\lib\x86;$(VC_LibraryPath_x86);$(DXSDK_DIR)Lib\x86;$(WindowsSDK_LibraryPath_x86)

Thanks for your insight into the problem.

2 Likes