Help please: error CS0101

Can anyone please help me?

I did everything according to Rick’s instructions, but I get this error -
Assets\Scripts\GameStatus.cs(17,10): error CS0111: Type ‘GameStatus’ already defines a member called ‘Update’ with the same parameter types

I just can’t find where the bug is.

Here are the screenshots. Any advice would be welcome!

Hi Roey,

Have you already tried to restart Unity and Visual Studio? If so, are there two GameStatus scripts in your Assets folder?

If not, try to click the right mouse button in your Assets folder, then on “Reimport” all. If that didn’t help either, close Unity and VS. Then navigate to your project folder and delete the .csproj and .sln files there. Maybe also the Library folder. Open Unity. The loading process might take a couple of minutes as Unity recreates files. Open your scene if you see an empty scene, which is Unity’s default scene.

Did this work?

See also:

It worked, thank you! I had two GameStatus scripts in my Assets folder indeed.

Thanks again.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms